java.lang.ExceptionInInitializerError

Exception #2578001

Samebug tips4

Update "latest" to Java 8 on DockerHub.

This might be caused by and outdated version of Java, SonarQube now uses Java 8 as default. You might upgrade java or use an older version of SonarQube.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web3120

Stack trace

  • java.lang.ExceptionInInitializerError at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:249) at com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:408) at com.intellij.openapi.components.impl.ComponentManagerImpl.init(ComponentManagerImpl.java:96) at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:455) at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:447) at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60) at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209) at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:715) at java.awt.EventQueue.access$400(EventQueue.java:82) at java.awt.EventQueue$2.run(EventQueue.java:676) at java.awt.EventQueue$2.run(EventQueue.java:674) at java.security.AccessController.doPrivileged(Native Method) at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86) at java.awt.EventQueue.dispatchEvent(EventQueue.java:685) at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:361) at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296) at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211) at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188) at java.awt.EventDispatchThread.run(EventDispatchThread.java:122) Caused by: com.intellij.diagnostic.PluginException: com/vladsch/idea/multimarkdown/settings/LicensingStateChanged : Unsupported major.minor version 52.0 [Plugin: com.vladsch.idea.multimarkdown] at com.intellij.ide.plugins.cl.PluginClassLoader.a(PluginClassLoader.java:130) at com.intellij.ide.plugins.cl.PluginClassLoader.a(PluginClassLoader.java:77) at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:66) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) at com.vladsch.idea.multimarkdown.MultiMarkdownPlugin.<clinit>(MultiMarkdownPlugin.kt:555) ... 27 more Caused by: java.lang.UnsupportedClassVersionError: com/vladsch/idea/multimarkdown/settings/LicensingStateChanged : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) at java.lang.ClassLoader.defineClass(ClassLoader.java:621) at java.lang.ClassLoader.defineClass(ClassLoader.java:471) at com.intellij.util.lang.UrlClassLoader._defineClass(UrlClassLoader.java:260) at com.intellij.util.lang.UrlClassLoader.defineClass(UrlClassLoader.java:256) at com.intellij.util.lang.UrlClassLoader._findClass(UrlClassLoader.java:225) at com.intellij.ide.plugins.cl.PluginClassLoader.a(PluginClassLoader.java:124) ... 31 more

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Unknown visitor
Unknown visitorOnce,
Unknown visitor
Unknown visitorOnce,
Unknown visitor
Unknown visitorOnce,
Unknown visitor
Unknown visitorOnce,
Unknown visitor
Unknown visitorOnce,
194 more bugmates