brut.androlib.AndrolibException

tip

This is a bug in some versions of the Arduino IDE. Try updating to the version 1.6.12 or further.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Regression: java -jar fails
    via GitHub by okias
    ,
  • GitHub comment 1306#241385947
    via GitHub by YMXZ
    ,
  • Apktool building error
    via Stack Overflow by host
    ,
  • GitHub comment 29#241728984
    via GitHub by dana-at-cp
    ,
  • GitHub comment 30#242115730
    via GitHub by dana-at-cp
    ,
  • GitHub comment 32#246417632
    via GitHub by dana-at-cp
    ,
  • GitHub comment 517#252477657
    via GitHub by eezym
    ,
    • brut.androlib.AndrolibException: brut.common.BrutException: could not exec: [/tmp/brut_util_Jar_2477187644452509808.tmp, p, -F, /tmp/tmpf8dvncua/framework.jar.out/dist/framework.jar, -0, arsc, /tmp/tmpf8dvncua/framework.jar.out/build/apk] at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:439) at brut.androlib.Androlib.buildApk(Androlib.java:670) at brut.androlib.Androlib.build(Androlib.java:310) at brut.androlib.Androlib.build(Androlib.java:263) at brut.apktool.Main.cmdBuild(Main.java:224) at brut.apktool.Main.main(Main.java:84) Caused by: brut.common.BrutException: could not exec: [/tmp/brut_util_Jar_2477187644452509808.tmp, p, -F, /tmp/tmpf8dvncua/framework.jar.out/dist/framework.jar, -0, arsc, /tmp/tmpf8dvncua/framework.jar.out/build/apk] at brut.util.OS.exec(OS.java:97) at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:433) ... 5 more Caused by: java.io.IOException: Cannot run program "/tmp/brut_util_Jar_2477187644452509808.tmp": error=2, No such file or directory at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048) at brut.util.OS.exec(OS.java:90) ... 6 more Caused by: java.io.IOException: error=2, No such file or directory at java.lang.UNIXProcess.forkAndExec(Native Method) at java.lang.UNIXProcess.<init>(UNIXProcess.java:248) at java.lang.ProcessImpl.start(ProcessImpl.java:134) at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029) ... 7 more

    Users with the same issue

    rp
    1 times, last one,
    Unknown visitor1 times, last one,
    rexgreenza
    8 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    150 more bugmates