org.openqa.selenium.StaleElementReferenceException

stale element reference: element is not attached to the page document (Session info: chrome=44.0.2403.89) (Driver info: chromedriver=2.9.248315,platform=Windows NT 6.1 SP1 x86)(WARNING: The server did not provide any stacktrace information) Command duration or timeout: 115 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: '2.46.0', revision: '87c69e2', time: '2015-06-04 16:17:10' System info: host: 'ShantanuNandan', ip: '10.0.0.4', os.name: 'Windows 7', os.arch: 'x86', os.version: '6.1', java.version: '1.8.0_45' Driver info: org.openqa.selenium.chrome.ChromeDriver Capabilities [{applicationCacheEnabled=false, rotatable=false, chrome= {userDataDir=C:\Users\SHANTA~1\AppData\Local\Temp\scoped_dir6172_17060}, takesHeapSnapshot=true, databaseEnabled=false, handlesAlerts=true, version=44.0.2403.89, platform=XP, browserConnectionEnabled=false, nativeEvents=true, acceptSslCerts=true, locationContextEnabled=true, webStorageEnabled=true, browserName=chrome, takesScreenshot=true, javascriptEnabled=true, cssSelectorsEnabled=true}] Session ID: 081ee44a67affb195766d4fc8ce165d3

Solutions on the web27

  • stale element reference: element is not attached to the page document (Session info: chrome=44.0.2403.89) (Driver info: chromedriver=2.9.248315,platform=Windows NT 6.1 SP1 x86)(WARNING: The server did not provide any stacktrace information) Command
  • server did not provide any stacktrace information) Command duration or timeout: 149 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: 'unknown', revision
  • via Google Groups by Unknown author, 3 weeks ago
    server did not provide any stacktrace information) Command duration or timeout: 26 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: '3.4.0', revision
  • Stack trace

    • org.openqa.selenium.StaleElementReferenceException: stale element reference: element is not attached to the page document (Session info: chrome=44.0.2403.89) (Driver info: chromedriver=2.9.248315,platform=Windows NT 6.1 SP1 x86)(WARNING: The server did not provide any stacktrace information) Command duration or timeout: 115 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: '2.46.0', revision: '87c69e2', time: '2015-06-04 16:17:10' System info: host: 'ShantanuNandan', ip: '10.0.0.4', os.name: 'Windows 7', os.arch: 'x86', os.version: '6.1', java.version: '1.8.0_45' Driver info: org.openqa.selenium.chrome.ChromeDriver Capabilities [{applicationCacheEnabled=false, rotatable=false, chrome= {userDataDir=C:\Users\SHANTA~1\AppData\Local\Temp\scoped_dir6172_17060}, takesHeapSnapshot=true, databaseEnabled=false, handlesAlerts=true, version=44.0.2403.89, platform=XP, browserConnectionEnabled=false, nativeEvents=true, acceptSslCerts=true, locationContextEnabled=true, webStorageEnabled=true, browserName=chrome, takesScreenshot=true, javascriptEnabled=true, cssSelectorsEnabled=true}] Session ID: 081ee44a67affb195766d4fc8ce165d3 at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) at java.lang.reflect.Constructor.newInstance(Unknown Source)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 1 day ago
    2 times, 2 months ago
    Unknown user
    Once, 2 years ago