org.openqa.selenium.StaleElementReferenceException: stale element reference: element is not attached to the page document (Session info: chrome=44.0.2403.89) (Driver info: chromedriver=2.9.248315,platform=Windows NT 6.1 SP1 x86)(WARNING: The server did not provide any stacktrace information) Command duration or timeout: 115 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: '2.46.0', revision: '87c69e2', time: '2015-06-04 16:17:10' System info: host: 'ShantanuNandan', ip: '10.0.0.4', os.name: 'Windows 7', os.arch: 'x86', os.version: '6.1', java.version: '1.8.0_45' Driver info: org.openqa.selenium.chrome.ChromeDriver Capabilities [{applicationCacheEnabled=false, rotatable=false, chrome= {userDataDir=C:\Users\SHANTA~1\AppData\Local\Temp\scoped_dir6172_17060}, takesHeapSnapshot=true, databaseEnabled=false, handlesAlerts=true, version=44.0.2403.89, platform=XP, browserConnectionEnabled=false, nativeEvents=true, acceptSslCerts=true, locationContextEnabled=true, webStorageEnabled=true, browserName=chrome, takesScreenshot=true, javascriptEnabled=true, cssSelectorsEnabled=true}] Session ID: 081ee44a67affb195766d4fc8ce165d3

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Stack Overflow by Shantanu Nandan
, 1 year ago
stale element reference: element is not attached to the page document (Session info: chrome=44.0.2403.89) (Driver info: chromedriver=2.9.248315,platform=Windows NT 6.1 SP1 x86)(WARNING: The server did not provide any stacktrace information) Command
via osdir.com by Unknown author, 2 years ago
Element belongs to a different frame than the current one - switch to its containing frame to use itCommand duration or timeout: 0 millisecondsFor documentation on this error, please visit: http://seleniumhq.org/exceptions
via Stack Overflow by Paul85
, 1 year ago
Element not found in the cache - perhaps the page has changed since it was looked up Command duration or timeout: 60.11 seconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info
via Google Groups by sele...@googlecode.com, 2 years ago
stale element reference: element is not attached to the page document Capabilities:[{applicationCacheEnabled=false, rotatable=false, chrome={userDataDir=/var/folders/4k/2w0rsfyx217_89pdbdns1s4c0000gn/T/.org.chromium.Chromium.uqV88r
via Stack Overflow by useR210961
, 10 months ago
server did not provide any stacktrace information) Command duration or timeout: 149 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: 'unknown', revision
via Stack Overflow by user2617199
, 1 year ago
Element is no longer valid (WARNING: The server did not provide any stacktrace information) Command duration or timeout: 15 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html
org.openqa.selenium.StaleElementReferenceException: stale element reference: element is not attached to the page document (Session info: chrome=44.0.2403.89) (Driver info: chromedriver=2.9.248315,platform=Windows NT 6.1 SP1 x86)(WARNING: The server did not provide any stacktrace information) Command duration or timeout: 115 milliseconds For documentation on this error, please visit: http://seleniumhq.org/exceptions/stale_element_reference.html Build info: version: '2.46.0', revision: '87c69e2', time: '2015-06-04 16:17:10' System info: host: 'ShantanuNandan', ip: '10.0.0.4', os.name: 'Windows 7', os.arch: 'x86', os.version: '6.1', java.version: '1.8.0_45' Driver info: org.openqa.selenium.chrome.ChromeDriver Capabilities [{applicationCacheEnabled=false, rotatable=false, chrome= {userDataDir=C:\Users\SHANTA~1\AppData\Local\Temp\scoped_dir6172_17060}, takesHeapSnapshot=true, databaseEnabled=false, handlesAlerts=true, version=44.0.2403.89, platform=XP, browserConnectionEnabled=false, nativeEvents=true, acceptSslCerts=true, locationContextEnabled=true, webStorageEnabled=true, browserName=chrome, takesScreenshot=true, javascriptEnabled=true, cssSelectorsEnabled=true}] Session ID: 081ee44a67affb195766d4fc8ce165d3
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

Users with the same issue

9 times, 3 weeks ago
2 times, 8 months ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.