org.osgi.framework.BundleException: Unresolved constraint in bundle test.osgi.primefaces [293]: Unable to resolve 293.0: missing requirement [293.0] osgi.wiring.bundle; (&(osgi.wiring.bundle=org.primefaces.osgi)(bundle-version>=1.0.0))

Stack Overflow | 0x56794E | 3 months ago
  1. 0

    How do I properly deploy Eclipse OSGI plug-in that I created?

    Stack Overflow | 3 months ago | 0x56794E
    org.osgi.framework.BundleException: Unresolved constraint in bundle test.osgi.primefaces [293]: Unable to resolve 293.0: missing requirement [293.0] osgi.wiring.bundle; (&(osgi.wiring.bundle=org.primefaces.osgi)(bundle-version>=1.0.0))
  2. 0

    Can't resolve bundles in a LocalOBR in v2

    GitHub | 4 years ago | gravelld
    org.osgi.framework.BundleException: Unresolved constraint in bundle com.elsten.util [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; (&(osgi.wiring.package=com.google.common.base)(version>=11.0.0)(!(version>=12.0.0)))
  3. Speed up your debug routine!

    Automated exception search integrated into your IDE

  4. 0

    Unresolved constraint in bundle and missing requirement osgi.wiring.package = org.quartz)(version>=2.2.0)(!(version>=3.0.0)))

    Stack Overflow | 3 years ago | Zilck
    org.osgi.framework.BundleException: Unresolved constraint in bundle employee.identitymanagement.web_client [516]: Unable to resolve 516.0: missing requirement [516.0] osgi.wiring.package; (&(osgi.wiring.package=org.quartz)(version>=2.2.0)(!(version>=3.0.0)))
  5. 0

    How to OSGIfy a library

    Stack Overflow | 4 years ago | stibi
    org.osgi.framework.BundleException: Unresolved constraint in bundle jiraclient.bundle [134]: Unable to resolve 134.0: missing requirement [134.0] osgi.wiring.package; (osgi.wiring.package=org.apache.commons.codec)

  1. davidvanlaatum 28 times, last 1 month ago
  2. davidvanlaatum 7 times, last 2 months ago
15 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle test.osgi.primefaces [293]: Unable to resolve 293.0: missing requirement [293.0] osgi.wiring.bundle; (&(osgi.wiring.bundle=org.primefaces.osgi)(bundle-version>=1.0.0))

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    BundleImpl.start
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
    3. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)
    3 frames