java.lang.UnsupportedClassVersionError

tip

Update "latest" to Java 8 on DockerHub.

tip

You're using an older version of java with classes compiled for java7

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • errors in Jython installation
    via Stack Overflow by Kranti Kumar
    ,
  • GitHub comment 1#260750427
    via GitHub by ibnesayeed
    ,
  • H2O Documentation
    via by Unknown author,
  • railo express not start on a mac
    via by Itcoder,
    • java.lang.UnsupportedClassVersionError: JVMCFRE003 bad major version; class=org/python/util/jython, offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:275) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:69) at java.net.URLClassLoader.defineClass(URLClassLoader.java:540) at java.net.URLClassLoader.defineClass(URLClassLoader.java:451) at java.net.URLClassLoader.access$300(URLClassLoader.java:79) at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1038) at java.security.AccessController.doPrivileged(AccessController.java:284) at java.net.URLClassLoader.findClass(URLClassLoader.java:429) at java.lang.ClassLoader.loadClass(ClassLoader.java:660) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:358) at java.lang.ClassLoader.loadClass(ClassLoader.java:626)

    Users with the same issue

    Eric HendersonEric Henderson
    1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    CasperCasper
    2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    chenjunjunchenjunjun
    1 times, last one,
    70 more bugmates