java.lang.NullPointerException

null

Samebug tips1

Take a look at this blog post on how to set up Grid2 https://goo.gl/rxzbE6. A user related (in the email group on the source) that using older selenium libs solves this exception.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web20382

  • null
  • via GitHub by todoubaba
    , 1 year ago
    null
  • null
  • Stack trace

    • java.lang.NullPointerException: null at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:210)[guava-18.0.jar:na] at org.everrest.core.impl.RequestDispatcher.<init>(RequestDispatcher.java:84)[everrest-core-1.13.1.jar:na] at org.eclipse.che.everrest.ServerContainerInitializeListener.getEverrestProcessor(ServerContainerInitializeListener.java:165)[che-core-api-core-5.0.0-M2-SNAPSHOT.jar:5.0.0-M2-SNAPSHOT] at org.eclipse.che.everrest.ServerContainerInitializeListener.createWsServerEndpointConfig(ServerContainerInitializeListener.java:123)[che-core-api-core-5.0.0-M2-SNAPSHOT.jar:5.0.0-M2-SNAPSHOT] at org.eclipse.che.everrest.ServerContainerInitializeListener.contextInitialized(ServerContainerInitializeListener.java:91)[che-core-api-core-5.0.0-M2-SNAPSHOT.jar:5.0.0-M2-SNAPSHOT] at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4812)[catalina.jar:8.0.32] at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5255)[catalina.jar:8.0.32] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147)[catalina.jar:8.0.32] at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:725)[catalina.jar:8.0.32] at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:701)[catalina.jar:8.0.32] at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:717)[catalina.jar:8.0.32] at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:939)[catalina.jar:8.0.32] at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1812)[catalina.jar:8.0.32] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[na:1.8.0_92-internal] at java.util.concurrent.FutureTask.run(FutureTask.java:266)[na:1.8.0_92-internal] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[na:1.8.0_92-internal] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[na:1.8.0_92-internal] at java.lang.Thread.run(Thread.java:745)[na:1.8.0_92-internal]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    6 times, 10 months ago
    8 times, 1 year ago
    3 times, 2 months ago
    Once, 5 months ago
    Unknown user
    Once, 1 year ago
    85 more bugmates