io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://192.168.64.13:8443/oapi/v1/namespaces/default/deploymentconfigs. Message: DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`. Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=spec.template.metadata.labels, message=Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`, reason=FieldValueInvalid, additionalProperties={})], group=null, kind=DeploymentConfig, name=simple-config-map, retryAfterSeconds=null, additionalProperties={}), kind=Status, message=DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`, metadata=ListMeta(resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={}).

GitHub | cmoulliard | 8 months ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    Message: DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map

    GitHub | 8 months ago | cmoulliard
    io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://192.168.64.13:8443/oapi/v1/namespaces/default/deploymentconfigs. Message: DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`. Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=spec.template.metadata.labels, message=Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`, reason=FieldValueInvalid, additionalProperties={})], group=null, kind=DeploymentConfig, name=simple-config-map, retryAfterSeconds=null, additionalProperties={}), kind=Status, message=DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`, metadata=ListMeta(resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={}).
  2. 0

    Seeing Errors with Camel examples

    GitHub | 7 months ago | stevef1uk
    io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://192.168.99.100:8443/apis/extensions/v1beta1/namespaces/default/deployments. Message: Deployment.extensions "camel-example-loan-broke" is invalid: spec.template.spec.containers: Required value. Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=spec.template.spec.containers, message=Required value, reason=FieldValueRequired, additionalProperties={})], group=extensions, kind=Deployment, name=camel-example-loan-broke, retryAfterSeconds=null, additionalProperties={}), kind=Status, message=Deployment.extensions "camel-example-loan-broke" is invalid: spec.template.spec.containers: Required value, metadata=ListMeta(resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={}).
  3. 0

    kubernetes-api: default values not supported

    GitHub | 1 year ago | WinstonSureChill
    io.fabric8.kubernetes.client.KubernetesClientException: Namespace not specified. But operation requires namespace.
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Unable to create project in CI/CD pipeline

    GitHub | 1 year ago | rhopp
    java.lang.RuntimeException: Failed to create BuildConfig from from project testNodeJSProject. io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://kubernetes.default.svc/oapi/v1/namespaces/default/buildconfigs. Message: BuildConfig "testNodeJSProject" is invalid: metadata.name: invalid value 'testNodeJSProject', Details: must be a DNS subdomain (at most 253 characters, matching regex [a-z0-9]([-a-z0-9]*[a-z0-9])?(\.[a-z0-9]([-a-z0-9]*[a-z0-9])?)*): e.g. "example.com". Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=metadata.name, message=invalid value 'testNodeJSProject', Details: must be a DNS subdomain (at most 253 characters, matching regex [a-z0-9]([-a-z0-9]*[a-z0-9])?(\.[a-z0-9]([-a-z0-9]*[a-z0-9])?)*): e.g. "example.com", reason=FieldValueInvalid, additionalProperties={})], kind=BuildConfig, name=testNodeJSProject, retryAfterSeconds=null, additionalProperties={}), kind=Status, message=BuildConfig "testNodeJSProject" is invalid: metadata.name: invalid value 'testNodeJSProject', Details: must be a DNS subdomain (at most 253 characters, matching regex [a-z0-9]([-a-z0-9]*[a-z0-9])?(\.[a-z0-9]([-a-z0-9]*[a-z0-9])?)*): e.g. "example.com", metadata=ListMeta(resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={}).
  6. 0

    GitHub comment 53#218853355

    GitHub | 1 year ago | alberttwong
    io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://kubernetes.default.svc/api/v1/namespaces/sample-project/configmaps. Message: the server could not find the requested resource. Received status: Status(apiVersion=v1, code=404, details=StatusDetails(causes=[], group=null, kind=null, name=null, retryAfterSeconds=null, additionalProperties={}), kind=Status, message=the server could not find the requested resource, metadata=ListMeta(resourceVersion=null, selfLink=null, additionalProperties={}), reason=NotFound, status=Failure, additionalProperties={}).

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. io.fabric8.kubernetes.client.KubernetesClientException

      Failure executing: POST at: https://192.168.64.13:8443/oapi/v1/namespaces/default/deploymentconfigs. Message: DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`. Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=spec.template.metadata.labels, message=Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`, reason=FieldValueInvalid, additionalProperties={})], group=null, kind=DeploymentConfig, name=simple-config-map, retryAfterSeconds=null, additionalProperties={}), kind=Status, message=DeploymentConfig "simple-config-map" is invalid: spec.template.metadata.labels: Invalid value: {"component":"simple-config-map","container":"vertx","expose":"true","group":"vertx-demo","project":"simple-config-map","provider":"fabric8","version":"1.0.0-SNAPSHOT"}: `selector` does not match template `labels`, metadata=ListMeta(resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={}).

      at io.fabric8.kubernetes.client.dsl.base.OperationSupport.requestFailure()
    2. io.fabric8.kubernetes
      BaseOperation.create
      1. io.fabric8.kubernetes.client.dsl.base.OperationSupport.requestFailure(OperationSupport.java:314)
      2. io.fabric8.kubernetes.client.dsl.base.OperationSupport.assertResponseCode(OperationSupport.java:267)
      3. io.fabric8.kubernetes.client.dsl.base.OperationSupport.handleResponse(OperationSupport.java:236)
      4. io.fabric8.kubernetes.client.dsl.base.OperationSupport.handleResponse(OperationSupport.java:229)
      5. io.fabric8.kubernetes.client.dsl.base.OperationSupport.handleCreate(OperationSupport.java:207)
      6. io.fabric8.kubernetes.client.dsl.base.BaseOperation.handleCreate(BaseOperation.java:547)
      7. io.fabric8.kubernetes.client.dsl.base.BaseOperation.create(BaseOperation.java:243)
      7 frames
    3. Fabric8 :: Kubernetes Client API
      Controller.apply
      1. io.fabric8.kubernetes.api.Controller.doCreateResource(Controller.java:938)
      2. io.fabric8.kubernetes.api.Controller.applyResource(Controller.java:927)
      3. io.fabric8.kubernetes.api.Controller.applyEntity(Controller.java:255)
      4. io.fabric8.kubernetes.api.Controller.apply(Controller.java:231)
      4 frames
    4. io.fabric8.maven
      AbstractFabric8Mojo.execute
      1. io.fabric8.maven.plugin.DeployMojo.applyEntities(DeployMojo.java:299)
      2. io.fabric8.maven.plugin.DeployMojo.executeInternal(DeployMojo.java:266)
      3. io.fabric8.maven.plugin.AbstractFabric8Mojo.execute(AbstractFabric8Mojo.java:49)
      3 frames
    5. Maven Plugin
      DefaultBuildPluginManager.executeMojo
      1. org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:132)
      1 frame
    6. Maven Core
      DefaultMaven.execute
      1. org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
      2. org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      3. org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      4. org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
      5. org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
      6. org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
      7. org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:120)
      8. org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:355)
      9. org.apache.maven.DefaultMaven.execute(DefaultMaven.java:155)
      9 frames
    7. M3 Interceptor
      MavenCli.main
      1. org.apache.maven.cli.MavenCli.execute(MavenCli.java:584)
      2. org.apache.maven.cli.MavenCli.doMain(MavenCli.java:216)
      3. org.apache.maven.cli.MavenCli.main(MavenCli.java:160)
      3 frames
    8. Java RT
      Method.invoke
      1. sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      2. sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      3. sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      4. java.lang.reflect.Method.invoke(Method.java:498)
      4 frames
    9. Plexus
      Launcher.main
      1. org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
      2. org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
      3. org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
      4. org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      4 frames