org.apache.lucene.index.IndexFormatTooOldException: Format version is not supported (resource BufferedChecksumIndexInput(MMapIndexInput(path="/mnt/HPT8_56T/infomall-index/index0/segments_5t3"))): 0 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 5.0 and later.

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Stack Overflow by suiyuan2009
, 1 year ago
Format version is not supported (resource BufferedChecksumIndexInput(MMapIndexInput(path="/mnt/HPT8_56T/infomall-index/index0/segments_5t3"))): 0 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 5.0 and later.
via Stack Overflow by Unknown author, 2 years ago
Format version is not supported (resource BufferedChecksumIndexInput(NIOFSIndexInput(path="/opt/xyz/index/1/index/segments_5b"))): -911482135 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 4.0 and later.
via GitHub by Jempan
, 1 year ago
Format version is not supported (resource BufferedChecksumIndexInput(MMapIndexInput(path="C:\neo4j-3.7\data\databases\graph.db\upgrade\index\lucene\node\geom__neo4j-spatial__LayerNodeIndex__internal__spatialNodeLookup__\segments_1"))): -11 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 4.0 and later.
via Stack Overflow by bastien
, 1 year ago
Format version is not supported (resource BufferedChecksumIndexInput(MMapIndexInput(path="/usr/local/Cellar/neo4j/3.0.0/libexec/data/databases/graph_ito.db/upgrade/index/lucene/node/Hr/segments_1"))): -11 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 4.0 and later.
org.apache.lucene.index.IndexFormatTooOldException: Format version is not supported (resource BufferedChecksumIndexInput(MMapIndexInput(path="/mnt/HPT8_56T/infomall-index/index0/segments_5t3"))): 0 (needs to be between 1071082519 and 1071082519). This version of Lucene only supports indexes created with release 5.0 and later.
at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:295)
at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:284)
at org.apache.lucene.index.IndexWriter.(IndexWriter.java:910)
at sewm.bdbox.search.InfomallIndexer.(InfomallIndexer.java:60)
at sewm.bdbox.search.ThreadedInfomallIndexer.(ThreadedInfomallIndexer.java:28)
at sewm.bdbox.search.ThreadedInfomallIndexer.(ThreadedInfomallIndexer.java:21)
at sewm.bdbox.search.ThreadedInfomallIndexer$Builder.build(ThreadedInfomallIndexer.java:72)
at sewm.bdbox.search.ThreadedInfomallIndexer.main(ThreadedInfomallIndexer.java:129)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.