java.lang.RuntimeException: java.net.BindException: Address already in use: bind

tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Need help please
    via GitHub by Smull99
    ,
  • Need help please
    via GitHub by Smull99
    ,
  • GitHub comment 904#238532716
    via GitHub by ia7maxd
    ,
  • Bot wont start
    via GitHub by qwertychacha2002
    ,
  • GitHub comment 806#238089841
    via GitHub by husbeard
    ,
  • GitHub comment 806#238089531
    via GitHub by zhoushifeng8
    ,
  • Error
    via GitHub by ramviknesh07
    ,
  • Login Problem
    via GitHub by Raven1994
    ,
    • java.lang.RuntimeException: java.net.BindException: Address already in use: bind at io.undertow.Undertow.start(Undertow.java:186) at org.springframework.boot.context.embedded.undertow.UndertowEmbeddedServletContainer.start(UndertowEmbeddedServletContainer.java:121) at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.startEmbeddedServletContainer(EmbeddedWebApplicationContext.java:293) at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.finishRefresh(EmbeddedWebApplicationContext.java:141) at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:541) at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(EmbeddedWebApplicationContext.java:118) at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:760) at org.springframework.boot.SpringApplication.createAndRefreshContext(SpringApplication.java:360) at org.springframework.boot.SpringApplication.run(SpringApplication.java:306) at org.springframework.boot.SpringApplication.run(SpringApplication.java:1185) at org.springframework.boot.SpringApplication.run(SpringApplication.java:1174) at ink.abb.pogo.scraper.MainKt.main(Main.kt:89) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:54) at org.springframework.boot.loader.Launcher.launch(Launcher.java:104) at org.springframework.boot.loader.Launcher.launch(Launcher.java:61) at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:52) Caused by: java.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) at org.xnio.nio.NioXnioWorker.createTcpConnectionServer(NioXnioWorker.java:190) at org.xnio.XnioWorker.createStreamConnectionServer(XnioWorker.java:243) at io.undertow.Undertow.start(Undertow.java:142) ... 19 more

    Users with the same issue

    Unknown visitor1 times, last one,
    musketyr
    musketyr9 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    136 more bugmates