java.lang.IllegalArgumentException

Plugin [analysis-kuromoji] is incompatible with Elasticsearch [2.3.4]. Was designed for version [2.3.2]

Solutions on the web14471

  • Plugin [analysis-kuromoji] is incompatible with Elasticsearch [2.3.4]. Was designed for version [2.3.2]
  • via GitHub by lonly197
    , 1 year ago
    Plugin [analysis-ik] is incompatible with Elasticsearch [2.3.4]. Was designed for version [2.3.3]
  • Plugin [lang-expression] is incompatible with Elasticsearch [2.3.0]. Was designed for version [2.3.2] ```
  • Stack trace

    • java.lang.IllegalArgumentException: Plugin [analysis-kuromoji] is incompatible with Elasticsearch [2.3.4]. Was designed for version [2.3.2] at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:118) at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:378) at org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:128) at org.elasticsearch.node.Node.<init>(Node.java:158) at org.elasticsearch.node.Node.<init>(Node.java:140) at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:143) at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178) at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:270) at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago