java.lang.ClassNotFoundException: org.apache.ws.commons.schema.resolver.URIResolver

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,

Make sure to add org.springframework.core-3.1.0.M2.jar to your project libraries so that org.springframework.core.env.EnvironmentCapable will be loaded.

,

Make sure to add org.springframework.core-3.1.0.M2.jar to your project libraries so that org.springframework.core.env.EnvironmentCapable will be loaded.

Solutions on the web

via co.jp by Unknown author, 1 year ago
via codegur.com by Unknown author, 1 year ago
org.apache.ws.commons.schema.resolver.URIResolver
via codegur.club by Unknown author, 1 year ago
org.apache.ws.commons.schema.resolver.URIResolver
via Stack Overflow by JosepB
, 2 months ago
org.apache.ws.commons.schema.resolver.URIResolver
via Stack Overflow by sandy
, 1 year ago
org.apache.ws.commons.schema.resolver.URIResolver
java.lang.ClassNotFoundException: org.apache.ws.commons.schema.resolver.URIResolver
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1305)
at org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDeployer.java:128)
at org.apache.axis2.deployment.repository.util.DeploymentFileData.deploy(DeploymentFileData.java:149)
at org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine.java:585)
at org.apache.axis2.deployment.RepositoryListener.init(RepositoryListener.java:264)
at org.apache.axis2.deployment.RepositoryListener.init2(RepositoryListener.java:66)
at org.apache.axis2.deployment.RepositoryListener.(RepositoryListener.java:61)
at org.apache.axis2.deployment.DeploymentEngine.loadRepository(DeploymentEngine.java:152)
at org.apache.axis2.deployment.WarBasedAxisConfigurator.getAxisConfiguration(WarBasedAxisConfigurator.java:233)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:64)
at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:620)
at org.apache.axis2.webapp.AxisAdminServlet.init(AxisAdminServlet.java:60)
at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1238)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1151)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1038)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4996)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5285)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:744)

Users with the same issue

2 times, 1 week ago
4 times, 1 week ago
Once, 2 weeks ago
14 times, 2 weeks ago
2 times, 2 weeks ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.