java.lang.IllegalArgumentException: Plugin [x-pack] is incompatible with Elasticsearch [5.0.0-beta1]. Was designed for version [5.0.0-alpha5]

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • вышел ES5.2.1
    via GitHub by greenx
    ,
  • GitHub comment 226#166341112
    via GitHub by bilsch
    ,
  • 2.2.0 Support
    via GitHub by marklit
    ,
  • 有支持ES2.3.4计划吗?
    via GitHub by lonly197
    ,
    • java.lang.IllegalArgumentException: Plugin [x-pack] is incompatible with Elasticsearch [5.0.0-beta1]. Was designed for version [5.0.0-alpha5] at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:108) at org.elasticsearch.plugins.ListPluginsCommand.execute(ListPluginsCommand.java:63) at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:69) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) at org.elasticsearch.cli.Command.main(Command.java:62) at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:42)

    Users with the same issue

    Unknown visitor1 times, last one,