java.lang.IllegalArgumentException: Plugin [x-pack] is incompatible with Elasticsearch [5.0.0-beta1]. Was designed for version [5.0.0-alpha5]

GitHub | markwalkom | 7 months ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    elasticsearch-plugin list error response

    GitHub | 7 months ago | markwalkom
    java.lang.IllegalArgumentException: Plugin [x-pack] is incompatible with Elasticsearch [5.0.0-beta1]. Was designed for version [5.0.0-alpha5]
  2. 0

    elasticsearch-plugin list error response

    GitHub | 7 months ago | markwalkom
    java.lang.IllegalArgumentException: Plugin [x-pack] is incompatible with Elasticsearch [5.0.0-beta1]. Was designed for version [5.0.0-alpha5]

    Root Cause Analysis

    1. java.lang.IllegalArgumentException

      Plugin [x-pack] is incompatible with Elasticsearch [5.0.0-beta1]. Was designed for version [5.0.0-alpha5]

      at org.elasticsearch.plugins.PluginInfo.readFromProperties()
    2. ElasticSearch
      ListPluginsCommand.execute
      1. org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:108)
      2. org.elasticsearch.plugins.ListPluginsCommand.execute(ListPluginsCommand.java:63)
      2 frames
    3. org.elasticsearch.cli
      Command.main
      1. org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
      2. org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96)
      3. org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:69)
      4. org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96)
      5. org.elasticsearch.cli.Command.main(Command.java:62)
      5 frames
    4. ElasticSearch
      PluginCli.main
      1. org.elasticsearch.plugins.PluginCli.main(PluginCli.java:42)
      1 frame