org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException

An error occurred while automatically activating bundle net.sourceforge.pmd.eclipse.plugin (1831).

Solutions on the web420

  • An error occurred while automatically activating bundle net.sourceforge.pmd.eclipse.plugin (1831).
  • via Eclipse Bugzilla by pietia.moo, 1 year ago
    An error occurred while automatically activating bundle ch.ethz.iks.slp (130).
  • via Eclipse Bugzilla by spektom, 1 year ago
    An error occurred while automatically activating bundle org.eclipse.wst.common.modulecore (1898).
  • Stack trace

    • org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle net.sourceforge.pmd.eclipse.plugin (1831). at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(Unknown Source) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(Unknown Source) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(Unknown Source) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(Unknown Source) at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(Unknown Source) at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(Unknown Source) at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(Unknown Source) at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(Unknown Source) at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(Unknown Source) at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(Unknown Source) at org.eclipse.ui.internal.WorkbenchPlugin$1.run(Unknown Source) at org.eclipse.swt.custom.BusyIndicator.showWhile(Unknown Source) at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Unknown Source) at org.eclipse.ui.internal.decorators.LightweightDecoratorDefinition$1.run(Unknown Source) at org.eclipse.core.runtime.SafeRunner.run(Unknown Source) at org.eclipse.core.runtime.Platform.run(Unknown Source) at org.eclipse.ui.internal.decorators.LightweightDecoratorDefinition.internalGetDecorator(Unknown Source) at org.eclipse.ui.internal.decorators.LightweightDecoratorDefinition.decorate(Unknown Source) at org.eclipse.ui.internal.decorators.LightweightDecoratorManager$LightweightRunnable.run(Unknown Source) at org.eclipse.core.runtime.SafeRunner.run(Unknown Source) at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.decorate(Unknown Source) at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.getDecorations(Unknown Source) at org.eclipse.ui.internal.decorators.DecorationScheduler$1.ensureResultCached(Unknown Source) at org.eclipse.ui.internal.decorators.DecorationScheduler$1.run(Unknown Source) at org.eclipse.core.internal.jobs.Worker.run(Unknown Source) Caused by: org.osgi.framework.BundleException: Exception in net.sourceforge.pmd.eclipse.plugin.PMDPlugin.start() of bundle net.sourceforge.pmd.eclipse.plugin. at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(Unknown Source) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(Unknown Source) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(Unknown Source) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(Unknown Source) at org.eclipse.osgi.framework.util.SecureAction.start(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(Unknown Source) ... 31 more Caused by: java.lang.UnsupportedClassVersionError: JVMCFRE003 bad major version; class=net/sourceforge/pmd/RuleSetFactory, offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(Unknown Source) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(Unknown Source) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(Unknown Source) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(Unknown Source) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(Unknown Source) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass_LockClassLoader(Unknown Source) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(Unknown Source) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(Unknown Source) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at net.sourceforge.pmd.eclipse.plugin.PMDPlugin.registerStandardRuleSets(Unknown Source) at net.sourceforge.pmd.eclipse.plugin.PMDPlugin.start(Unknown Source) at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Unknown Source) ... 37 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    16 more bugmates