clojure.lang.Compiler$CompilerException

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.


rafaelrafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Building Storm (on Mac OS X)
    via by Christian Müller,
  • Re: Building Storm (on Mac OS X)
    via by Lasantha Fernando,
  • ZeroMQ Development Mailing List ()
    via by Unknown author,
  • Java Path zeromq setting
    via by Unknown author,
    • clojure.lang.Compiler$CompilerException: java.lang.UnsatisfiedLinkError: no jzmq in java.library.path, compiling:(zmq.clj:1) at clojure.lang.Compiler$InvokeExpr.eval(Compiler.java:3387)[clojure-1.4.0.jar:na] at clojure.lang.Compiler.compile1(Compiler.java:7035)[clojure-1.4.0.jar:na] at clojure.lang.Compiler.compile1(Compiler.java:7025)[clojure-1.4.0.jar:na] at clojure.lang.Compiler.compile(Compiler.java:7097)[clojure-1.4.0.jar:na] at clojure.lang.RT.compile(RT.java:387)[clojure-1.4.0.jar:na] at clojure.lang.RT.load(RT.java:427)[clojure-1.4.0.jar:na] at clojure.lang.RT.load(RT.java:400)[clojure-1.4.0.jar:na] at clojure.core$load$fn__4890.invoke(core.clj:5415)[clojure-1.4.0.jar:na] at clojure.core$load.doInvoke(core.clj:5414)[clojure-1.4.0.jar:na] at clojure.lang.RestFn.invoke(RestFn.java:408)[clojure-1.4.0.jar:na] at clojure.core$load_one.invoke(core.clj:5227)[clojure-1.4.0.jar:na] at clojure.core$compile$fn__4895.invoke(core.clj:5426)[clojure-1.4.0.jar:na] at clojure.core$compile.invoke(core.clj:5425)[clojure-1.4.0.jar:na] at user$eval9.invoke(form-init7247229328487019774.clj:1)[na:na] at clojure.lang.Compiler.eval(Compiler.java:6511)[clojure-1.4.0.jar:na] at clojure.lang.Compiler.eval(Compiler.java:6501)[clojure-1.4.0.jar:na] at clojure.lang.Compiler.load(Compiler.java:6952)[clojure-1.4.0.jar:na] at clojure.lang.Compiler.loadFile(Compiler.java:6912)[clojure-1.4.0.jar:na] at clojure.main$load_script.invoke(main.clj:283)[clojure-1.4.0.jar:na] at clojure.main$init_opt.invoke(main.clj:288)[clojure-1.4.0.jar:na] at clojure.main$initialize.invoke(main.clj:316)[clojure-1.4.0.jar:na] at clojure.main$null_opt.invoke(main.clj:349)[clojure-1.4.0.jar:na] at clojure.main$main.doInvoke(main.clj:427)[clojure-1.4.0.jar:na] at clojure.lang.RestFn.invoke(RestFn.java:421)[clojure-1.4.0.jar:na] at clojure.lang.Var.invoke(Var.java:419)[clojure-1.4.0.jar:na] at clojure.lang.AFn.applyToHelper(AFn.java:163)[clojure-1.4.0.jar:na] at clojure.lang.Var.applyTo(Var.java:532)[clojure-1.4.0.jar:na] at clojure.main.main(main.java:37)[clojure-1.4.0.jar:na] Caused by: java.lang.UnsatisfiedLinkError: no jzmq in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1758)[na:1.6.0_43] at java.lang.Runtime.loadLibrary0(Runtime.java:823)[na:1.6.0_43] at java.lang.System.loadLibrary(System.java:1045)[na:1.6.0_43] at org.zeromq.ZMQ.<clinit>(ZMQ.java:34)[jzmq-2.1.0.jar:na] at java.lang.Class.forName0(Native Method)[na:1.6.0_43] at java.lang.Class.forName(Class.java:171)[na:1.6.0_43] at backtype.storm.messaging.zmq$loading__4784__auto__.invoke(zmq.clj:1)[classes/:na] at clojure.lang.AFn.applyToHelper(AFn.java:159)[clojure-1.4.0.jar:na] at clojure.lang.AFn.applyTo(AFn.java:151)[clojure-1.4.0.jar:na] at clojure.lang.Compiler$InvokeExpr.eval(Compiler.java:3382)[clojure-1.4.0.jar:na] ... 27 more

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown UserUnknown User
    4 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    ReichReich
    2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    276 more bugmates