java.lang.RuntimeException

Safemode data missing [/blur/clusters/default/safemode] at >> org.apache.blur.manager.indexserver.DistributedIndexServer.waitInSafeModeIfNeeded(DistributedIndexServer.java:177) at >> org.apache.blur.manager.indexserver.DistributedIndexServer.init(DistributedIndexServer.java:135) at >> org.apache.blur.thrift.ThriftBlurServer.createServer(ThriftBlurServer.java:187) at org.apache.blur.thrift.ThriftBlurServer.main(ThriftBlurServer.java:88) >> > >> > This could be a bug with an empty ZooKeeper (meaning maybe blur isn't >> > setting things up correctly). I'm going to retest that blur sets up >> > ZooKeeper correctly for safe mode and report back. >> > >> > when I run the client $./apache-blur-0.2.0-SNAPSHOT/bin/blur shell localhost:40020 java.lang.NoSuchMethodError: org.apache.thrift.meta_data.FieldValueMetaData.<init>(BZ)V

Samebug tips0

There are no available Samebug tips.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web4

  • via by Li Li,
  • via by Aaron McCurry,
  • via by Li Li,
  • Stack trace

    • java.lang.RuntimeException: Safemode data missing [/blur/clusters/default/safemode] at >> org.apache.blur.manager.indexserver.DistributedIndexServer.waitInSafeModeIfNeeded(DistributedIndexServer.java:177) at >> org.apache.blur.manager.indexserver.DistributedIndexServer.init(DistributedIndexServer.java:135) at >> org.apache.blur.thrift.ThriftBlurServer.createServer(ThriftBlurServer.java:187) at org.apache.blur.thrift.ThriftBlurServer.main(ThriftBlurServer.java:88) >> > >> > This could be a bug with an empty ZooKeeper (meaning maybe blur isn't >> > setting things up correctly). I'm going to retest that blur sets up >> > ZooKeeper correctly for safe mode and report back. >> > >> > when I run the client $./apache-blur-0.2.0-SNAPSHOT/bin/blur shell localhost:40020 java.lang.NoSuchMethodError: org.apache.thrift.meta_data.FieldValueMetaData.<init>(BZ)V at org.apache.blur.thrift.generated.QueryArgs.<clinit>(QueryArgs.java:255) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:169) at $Proxy0.<clinit>(Unknown Source)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    No Bugmate found.