java.net.SocketException

Permission denied: connect

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web1135

  • Permission denied: connect
  • via Google Groups by Vivian Sank, 6 months ago
    Permission denied: connect
  • via Google Groups by MG12, 1 year ago
    Permission denied: connect
  • Stack trace

    • java.net.SocketException: Permission denied: connect at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method)[rt.jar:1.8.0_51] at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)[rt.jar:1.8.0_51] at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)[rt.jar:1.8.0_51] at java.net.AbstractPlainSocketImpl.connect(Unknown Source)[rt.jar:1.8.0_51] at java.net.PlainSocketImpl.connect(Unknown Source)[rt.jar:1.8.0_51] at java.net.SocksSocketImpl.connect(Unknown Source)[rt.jar:1.8.0_51] at java.net.Socket.connect(Unknown Source)[rt.jar:1.8.0_51] at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler$Proxy.getConnection(DefaultMCMPHandler.java:818) at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler$Proxy.getConnectionWriter(DefaultMCMPHandler.java:841) at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.sendRequest(DefaultMCMPHandler.java:482) at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.sendRequest(DefaultMCMPHandler.java:583) at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.status(DefaultMCMPHandler.java:370) at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.status(DefaultMCMPHandler.java:350) at org.jboss.modcluster.ModClusterService.status(ModClusterService.java:458) at org.jboss.modcluster.container.catalina.CatalinaEventHandlerAdapter.lifecycleEvent(CatalinaEventHandlerAdapter.java:249) at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:115)[jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1] at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1323)[jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1] at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1588)[jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1] at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1574)[jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1] at java.lang.Thread.run(Unknown Source)[rt.jar:1.8.0_51]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    2 times, 1 year ago
    Unknown user
    Once, 1 year ago
    2 times, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    64 more bugmates