org.apache.commons.httpclient.ProtocolException

The server ssltest.tnsi.com failed to respond with a valid HTTP response


Solutions on the web27

Solution icon of apache
via hc-httpclient-users by Ben Poweski, 10 months ago
The server ssltest.tnsi.com failed to respond with a valid HTTP response

Solution icon of apache
The server .... failed to respond with a valid HTTP response

Solution icon of web
The server .... failed to respond with a valid HTTP response

Solution icon of apache
The server .... failed to respond with a valid HTTP response

Solution icon of oraclecommunity
via Oracle Community by 807569, 1 year ago
The server failed to respond with a valid HTTP response

Solution icon of github
The server zot.com failed to respond with a valid HTTP response

Solution icon of web
via JIRA by MORPHO, 8 months ago
The server jira.xxxx failed to respond with a valid HTTP response

Solution icon of atlassian
via Atlassian JIRA by Martin Meinhold, 1 year ago
The server 127.0.0.1 failed to respond with a valid HTTP response

Solution icon of stackoverflow
via Stack Overflow by dario111cro
, 1 year ago
The server xxxxx failed to respond with a valid HTTP response

Stack trace

  • org.apache.commons.httpclient.ProtocolException: The server ssltest.tnsi.com failed to respond with a valid HTTP response at org.apache.commons.httpclient.HttpMethodBase.readStatusLine(HttpMethodBase.java:1850) at org.apache.commons.httpclient.HttpMethodBase.readResponse(HttpMethodBase.java:1599) at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1010) at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:392) at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:178) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:437) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324) at com.ta.vital.net.TestConnection.testConnect(TestConnection.java:65) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:324) at junit.framework.TestCase.runTest(TestCase.java:154) at junit.framework.TestCase.runBare(TestCase.java:127) at junit.framework.TestResult$1.protect(TestResult.java:106) at junit.framework.TestResult.runProtected(TestResult.java:124) at junit.framework.TestResult.run(TestResult.java:109) at junit.framework.TestCase.run(TestCase.java:118) at junit.framework.TestSuite.runTest(TestSuite.java:208) at junit.framework.TestSuite.run(TestSuite.java:203) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:421) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:305) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:186)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago