java.lang.Exception

Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web4736

  • via karaf-user by Jean-Baptiste Onofré, 2 weeks ago
    Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  • via karaf-user by Guofeng Zhang, 9 months ago
    Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  • via karaf-user by Guofeng Zhang, 2 weeks ago
    Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  • Stack trace

    • java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0))) at org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:407)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:362)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT] at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:1027)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT] Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.2.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.2.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.2.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.2.jar:] at org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:404)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT] ... 2 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 10 months ago
    28 times, 8 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    16 more bugmates