java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))

karaf-user | Guofeng Zhang | 5 years ago
  1. 0

    Karaf 3.0.0-SNAPSHOT not works

    karaf-user | 5 years ago | Guofeng Zhang
    java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  2. 0

    Karaf 3.0.0-SNAPSHOT not works

    karaf-user | 5 years ago | Guofeng Zhang
    java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  3. 0

    Build from trunk not loading JBI

    servicemix-users | 6 years ago | Scott Came
    java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Re: Build from trunk not loading JBI

    servicemix-users | 6 years ago | Jean-Baptiste Onofré
    java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
  6. 0

    admaDIC Blog: JDK8: Unable to Resolve javax.swing ?

    admadic.com | 1 year ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle example.swing1 [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.swing)

  1. davidvanlaatum 28 times, last 1 month ago
  2. davidvanlaatum 7 times, last 2 months ago
15 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    BundleImpl.start
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.2.jar:]
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.2.jar:]
    3. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.2.jar:]
    4. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.2.jar:]
    4 frames
  3. Pax Runner
    FeaturesServiceImpl$1.run
    1. org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:404)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
    2. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:362)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
    3. org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:1027)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
    3 frames