org.apache.maven.lifecycle.LifecycleExecutionException

Missing: ---------- 1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.ode -DartifactId=ode-jbi \ -Dversion=2.0-SNAPSHOT -Dpackaging=zip -Dfile=/path/to/file Path to dependency: 1) org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT 2) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT ---------- 1 required artifact is missing. for artifact: org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT from the specified remote repositories: central (http://repo1.maven.org/maven2), intalio (http://pxe.intalio.org/public/maven2), apache-incubator (http://people.apache.org/repo/m2-incubating-repository) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa ultLifecycleExecutor.java:551) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi fecycle(DefaultLifecycleExecutor.java:475) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau ltLifecycleExecutor.java:454) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan dleFailures(DefaultLifecycleExecutor.java:306) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen ts(DefaultLifecycleExecutor.java:273) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi fecycleExecutor.java:140)

Solutions on the web4718

  • via ode-user by Vo, Khanh, 9 months ago
    Missing: ---------- 1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.ode -DartifactId
  • via ode-user by Vo, Khanh, 9 months ago
    Missing: ---------- 1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.ode -DartifactId
  • via ode-user by Alex Boisvert, 9 months ago
    Missing: ---------- 1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.ode -DartifactId
  • Stack trace

    • org.apache.maven.lifecycle.LifecycleExecutionException: Missing: ---------- 1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.ode -DartifactId=ode-jbi \ -Dversion=2.0-SNAPSHOT -Dpackaging=zip -Dfile=/path/to/file Path to dependency: 1) org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT 2) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT ---------- 1 required artifact is missing. for artifact: org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT from the specified remote repositories: central (http://repo1.maven.org/maven2), intalio (http://pxe.intalio.org/public/maven2), apache-incubator (http://people.apache.org/repo/m2-incubating-repository) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa ultLifecycleExecutor.java:551) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi fecycle(DefaultLifecycleExecutor.java:475) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau ltLifecycleExecutor.java:454) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan dleFailures(DefaultLifecycleExecutor.java:306) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen ts(DefaultLifecycleExecutor.java:273) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi fecycleExecutor.java:140) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:322) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115) at org.apache.maven.cli.MavenCli.main(MavenCli.java:256) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 month ago
    Unknown user
    Once, 4 months ago
    2 times, 10 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    28 more bugmates