org.apache.accumulo.core.client.AccumuloSecurityException: Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM <mailto:central@EXAMPLE.COM>' - Username or Password is Invalid

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via accumulo-user by Tristen Georgiou, 1 year ago
Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM <mailto:central@EXAMPLE.COM>' - Username or Password is Invalid
via accumulo-user by Josh Elser, 1 year ago
Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM <mailto:central@EXAMPLE.COM>' - Username or Password is Invalid
via accumulo-user by Josh Elser, 1 year ago
Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM <mailto:central@EXAMPLE.COM>' - Username or Password is Invalid
via accumulo-user by Tristen Georgiou, 4 months ago
Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM <mailto:central@EXAMPLE.COM>' - Username or Password is Invalid
via accumulo-user by Tristen Georgiou, 1 year ago
Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM' - Username or Password is Invalid
via accumulo-user by Tristen Georgiou, 1 year ago
Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM' - Username or Password is Invalid
org.apache.accumulo.core.client.AccumuloSecurityException: Error BAD_CREDENTIALS for user Principal in credentials object should match kerberos principal. Expected 'accumulo/mas3.example.com@example.COM' but was 'central@EXAMPLE.COM <mailto:central@EXAMPLE.COM>' - Username or Password is Invalid
at org.apache.accumulo.core.client.impl.ServerClient.execute(ServerClient.java:63)
at org.apache.accumulo.core.client.impl.ConnectorImpl.(ConnectorImpl.java:67)
at org.apache.accumulo.proxy.ProxyServer.getConnector(ProxyServer.java:232)
at org.apache.accumulo.proxy.ProxyServer.login(ProxyServer.java:1574)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.apache.accumulo.core.trace.wrappers.RpcServerInvocationHandler.invoke(RpcServerInvocationHandler.java:39)
at org.apache.accumulo.server.rpc.RpcWrapper$1.invoke(RpcWrapper.java:47)
at com.sun.proxy.$Proxy14.login(Unknown Source)
at org.apache.accumulo.proxy.thrift.AccumuloProxy$Processor$login.getResult(AccumuloProxy.java:5723)
at org.apache.accumulo.proxy.thrift.AccumuloProxy$Processor$login.getResult(AccumuloProxy.java:5707)
at org.apache.thrift.ProcessFunction.process(ProcessFunction.java:39)
at org.apache.thrift.TBaseProcessor.process(TBaseProcessor.java:39)
at org.apache.accumulo.server.rpc.UGIAssumingProcessor.process(UGIAssumingProcessor.java:102)
at org.apache.accumulo.server.rpc.TimedProcessor.process(TimedProcessor.java:63)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at org.apache.accumulo.fate.util.LoggingRunnable.run(LoggingRunnable.java:35)
at java.lang.Thread.run(Thread.java:745)

Users with the same issue

You are the first who have seen this exception. Write a tip to help other users and build your expert profile.

Know the solutions? Share your knowledge to help other developers to debug faster.