java.net.BindException: Address already in use

tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafael
tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Hama not using existing Zookeeper quorom
    via by Himanshu Gahlot,
  • Re: Hama not using existing Zookeeper quorom
    via by Edward J. Yoon,
  • Re: Hama not using existing Zookeeper quorom
    via by Himanshu Gahlot,
  • Hama not using existing Zookeeper quorom
    via by Himanshu Gahlot,
  • Re: Hama not using existing Zookeeper quorom
    via by Edward J. Yoon,
  • Re: Hama not using existing Zookeeper quorom
    via by Himanshu Gahlot,
  • [résolu]Problème RegisterGameServer.sh
    via by Unknown author,
  • Build failed in Hudson: Cassandra #286
    via by Apache Hudson Server,
  • Build failed in Hudson: Cassandra #287
    via by Apache Hudson Server,
  • Build failed in Hudson: Cassandra #288
    via by Apache Hudson Server,
    • java.net.BindException: Address already in use at sun.nio.ch.Net.bind(Native Method) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:119) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:52) at org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:144) at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:121) at org.apache.hama.zookeeper.QuorumPeer.runZKServer(QuorumPeer.java:80) at org.apache.hama.zookeeper.QuorumPeer.run(QuorumPeer.java:70) at org.apache.hama.ZooKeeperRunner.run(ZooKeeperRunner.java:36) at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65) at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:79) at org.apache.hama.ZooKeeperRunner.main(ZooKeeperRunner.java:41)

    Users with the same issue

    bandoca
    bandoca122 times, last one,
    slash
    slash5 times, last one,
    rocday
    rocday1 times, last one,
    batwalrus76
    batwalrus761 times, last one,
    musketyr
    musketyr9 times, last one,
    129 more bugmates