java.net.BindException: Address already in use


Samebug tips

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.


5 months ago
Expert tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


7 months ago
Expert tip

Solutions on the web

Solution icon of apache
via incubator-hama-user by Edward J. Yoon, 1 year ago
Address already in use

Solution icon of apache
via incubator-hama-user by Himanshu Gahlot, 1 year ago
Address already in use

Solution icon of apache
via incubator-hama-user by Himanshu Gahlot, 1 year ago
Address already in use

Solution icon of apache
via incubator-hama-user by Himanshu Gahlot, 1 year ago
Address already in use

Solution icon of apache
via incubator-hama-user by Edward J. Yoon, 1 year ago
Address already in use

Solution icon of apache
via incubator-hama-user by Himanshu Gahlot, 1 year ago
Address already in use

Solution icon of github
via GitHub by agarwlGaurav
, 1 year ago
Address already in use

Solution icon of googlegroups
via Google Groups by ces, 4 months ago
Address already in use

Solution icon of googlegroups
via Google Groups by valia, 3 months ago
Address already in use

Solution icon of googlegroups
via Google Groups by 敬錞潘, 1 year ago
Address already in use

Stack trace

java.net.BindException: Address already in use
	at sun.nio.ch.Net.bind(Native Method)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:119)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:52)
	at org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:144)
	at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:121)
	at org.apache.hama.zookeeper.QuorumPeer.runZKServer(QuorumPeer.java:80)
	at org.apache.hama.zookeeper.QuorumPeer.run(QuorumPeer.java:70)
	at org.apache.hama.ZooKeeperRunner.run(ZooKeeperRunner.java:36)
	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:79)
	at org.apache.hama.ZooKeeperRunner.main(ZooKeeperRunner.java:41)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

4 times, 2 days ago
59 times, 1 week ago
2 times, 1 week ago
24 times, 1 week ago
146 more bugmates