java.lang.NoClassDefFoundError: org/apache/ws/java2wsdl/SchemaGenerator at org.apache.axis2.deployment.util.Utils.fillAxisService(Utils.java:272) at org.eclipse.corona.soa.provider.axis2.internal.AdminServiceImpl.deployRP CService(AdminServiceImpl.java:148) at org.eclipse.corona.soa.provider.axis2.internal.AdminServiceImpl.deploySe rvice(AdminServiceImpl.java:159)

ws-muse-user | Mario Prettner | 9 years ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    Re: Axis2 OSGi Deployment - Problem using SOAPProvider

    ws-muse-user | 9 years ago | Mario Prettner
    java.lang.NoClassDefFoundError: org/apache/ws/java2wsdl/SchemaGenerator at org.apache.axis2.deployment.util.Utils.fillAxisService(Utils.java:272) at org.eclipse.corona.soa.provider.axis2.internal.AdminServiceImpl.deployRP CService(AdminServiceImpl.java:148) at org.eclipse.corona.soa.provider.axis2.internal.AdminServiceImpl.deploySe rvice(AdminServiceImpl.java:159)

    Root Cause Analysis

    1. java.lang.NoClassDefFoundError

      org/apache/ws/java2wsdl/SchemaGenerator at org.apache.axis2.deployment.util.Utils.fillAxisService(Utils.java:272) at org.eclipse.corona.soa.provider.axis2.internal.AdminServiceImpl.deployRP CService(AdminServiceImpl.java:148) at org.eclipse.corona.soa.provider.axis2.internal.AdminServiceImpl.deploySe rvice(AdminServiceImpl.java:159)

      at ws1.Activator$SoapServiceTracker.addingService()
    2. ws1
      Activator$SoapServiceTracker.addingService
      1. ws1.Activator$SoapServiceTracker.addingService(Activator.java:66)
      1 frame