org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.stanbol.enhancer.engines.refactor [72]: Unable to resolve 72.0: missing requirement [72.0] package; (&(package=org.apache.stanbol.ontologymanager.servicesapi.collector)(version>=0.10.0)(!(version>=1.0.0)))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via stanbol-dev by Alessandro Adamou, 1 year ago
Unresolved constraint in bundle org.apache.stanbol.enhancer.engines.refactor [72]: Unable to resolve 72.0: missing requirement [72.0] package; (&(package=org.apache.stanbol.ontologymanager.servicesapi.collector)(version>=0.10.0)(!(version>=1.0.0)))
via stanbol-dev by Daniele Perlo, 1 year ago
Unresolved constraint in bundle org.apache.stanbol.enhancer.engines.refactor [72]: Unable to resolve 72.0: missing requirement [72.0] package; (&(package=org.apache.stanbol.ontologymanager.servicesapi.collector)(version>=0.10.0)(!(version>=1.0.0)))
via stanbol-dev by Alessandro Adamou, 1 year ago
Unresolved constraint in bundle org.apache.stanbol.enhancer.engines.refactor [72]: Unable to resolve 72.0: missing requirement [72.0] package; (&(package=org.apache.stanbol.ontologymanager.servicesapi.collector)(version>=0.10.0)(!(version>=1.0.0)))
via stanbol-dev by Daniele Perlo, 4 months ago
Unresolved constraint in bundle > org.apache.stanbol.enhancer.engines.refactor [72]: Unable to resolve 72.0: > missing requirement [72.0] package; > (&(package=org.apache.stanbol.ontologymanager.servicesapi.collector)(version>=0.10.0)(!(version>=1.0.0)))
via Oracle Community by 683da9ae-ca7b-4f67-a5ee-b2e621f8df84, 1 year ago
Unresolved constraint in bundle org.apache.sling.adapter [72]: Unable to resolve 72.0: missing requirement [72.0] package; (&(package=org.apache.sling.api.adapter)(version>=2.2.0)(!(version>=2.3.0))) [caused by: Unable to resolve 79.0: missing requirement [79.0] package; (&(package=javax.servlet)(version>=2.4.0))]
via GitHub by rchawdry
, 2 years ago
Unresolved constraint in bundle org.apache.karaf.diagnostic.command [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (package=javax.security.auth)]
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.stanbol.enhancer.engines.refactor [72]: Unable to resolve 72.0: missing requirement [72.0] package; (&(package=org.apache.stanbol.ontologymanager.servicesapi.collector)(version>=0.10.0)(!(version>=1.0.0)))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3443)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1727)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1156)
at java.lang.Thread.run(Thread.java:724)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
2 times, 9 months ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
2 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.