java.io.IOException

tip

You might be using the wrong way to add commands to the command line. Try using commandDownloader.add("command");

tip

If you're trying to make a splash screen, check this tutorial: https://goo.gl/zQyCYe

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Re: Sqoop to Hive Import
    via by Cyril Bogus,
  • Sqoop to Hive Import
    via by Cyril Bogus,
  • Re: Sqoop to Hive Import
    via by vasanth kumar,
  • Display the imported table in HDFS using sqoop
    via Stack Overflow by John x
    ,
  • Re: Error while starting the collector
    via by Ahmed Fathalla,
  • Re: Error while starting the collector
    via by Ahmed Fathalla,
  • Re: Error while starting the collector
    via by Ahmed Fathalla,
  • Re: Error while starting the collector
    via by Ahmed Fathalla,
    • java.io.IOException: error=2, No such file or directory at java.lang.ProcessBuilder.start(ProcessBuilder.java:460) at java.lang.Runtime.exec(Runtime.java:593) at java.lang.Runtime.exec(Runtime.java:509) at org.apache.sqoop.util.Executor.exec(Executor.java:76) at org.apache.sqoop.hive.HiveImport.executeExternalHiveScript(HiveImport.java:361) at org.apache.sqoop.hive.HiveImport.executeScript(HiveImport.java:314) at org.apache.sqoop.hive.HiveImport.importTable(HiveImport.java:226) at org.apache.sqoop.tool.ImportTool.importTable(ImportTool.java:415) at org.apache.sqoop.tool.ImportTool.run(ImportTool.java:476) at org.apache.sqoop.Sqoop.run(Sqoop.java:145) at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65) at org.apache.sqoop.Sqoop.runSqoop(Sqoop.java:181) at org.apache.sqoop.Sqoop.runTool(Sqoop.java:220) at org.apache.sqoop.Sqoop.runTool(Sqoop.java:229) at org.apache.sqoop.Sqoop.main(Sqoop.java:238) at com.cloudera.sqoop.Sqoop.main(Sqoop.java:57) Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory at java.lang.UNIXProcess.<init>(UNIXProcess.java:148) at java.lang.ProcessImpl.start(ProcessImpl.java:65) at java.lang.ProcessBuilder.start(ProcessBuilder.java:453) ... 15 more

    Users with the same issue

    PKeidel
    3 times, last one,
    serious2monkeys
    1 times, last one,
    Handemelindo
    6 times, last one,
    kid
    5 times, last one,
    Unknown visitor1 times, last one,
    83 more bugmates