org.osgi.service.blueprint.container.ComponentDefinitionException

Unable to validate xml

Solutions on the web175

  • via aries-user by lb, 3 weeks ago
    Unable to validate xml
  • via karaf-user by Aritra Chatterjee, 9 months ago
    Unable to validate xml
  • via nabble.com by Unknown author, 1 year ago
    Unable to validate xml
  • Stack trace

    • org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to validate xml at org.apache.aries.blueprint.parser.Parser.validate(Parser.java:288)[7:org.apache.aries.blueprint.core:1.1.0] at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:313)[7:org.apache.aries.blueprint.core:1.1.0] at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:261)[7:org.apache.aries.blueprint.core:1.1.0] at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:259)[7:org.apache.aries.blueprint.core:1.1.0] at org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:222)[7:org.apache.aries.blueprint.core:1.1.0] at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:500)[11:org.apache.aries.util:1.1.0] at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:433)[11:org.apache.aries.util:1.1.0] at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.track(BundleHookBundleTracker.java:725)[11:org.apache.aries.util:1.1.0] at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.bundleChanged(BundleHookBundleTracker.java:463)[11:org.apache.aries.util:1.1.0] at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$BundleEventHook.event(BundleHookBundleTracker.java:422)[11:org.apache.aries.util:1.1.0] at org.eclipse.osgi.framework.internal.core.Framework$10.call(Framework.java:1606)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.internal.serviceregistry.ServiceRegistry.notifyHookPrivileged(ServiceRegistry.java:1239)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.internal.serviceregistry.ServiceRegistry.notifyHooksPrivileged(ServiceRegistry.java:1222)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.Framework.notifyEventHooksPrivileged(Framework.java:1603)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.Framework.publishBundleEventPrivileged(Framework.java:1558)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.Framework.publishBundleEvent(Framework.java:1505)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.Framework.publishBundleEvent(Framework.java:1500)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:391)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:300)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.resumeBundles(PackageAdminImpl.java:312)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.processDelta(PackageAdminImpl.java:556)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.doResolveBundles(PackageAdminImpl.java:251)[osgi-3.8.0.v20120529-1548.jar:] at org.eclipse.osgi.framework.internal.core.PackageAdminImpl$1.run(PackageAdminImpl.java:174)[osgi-3.8.0.v20120529-1548.jar:] at java.lang.Thread.run(Thread.java:724)[:1.7.0_25] Caused by: org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'p:externalAttachment'. at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(UnknownSource)[:] at org.apache.xerces.util.ErrorHandlerWrapper.error(UnknownSource)[:] at org.apache.xerces.impl.XMLErrorReporter.reportError(UnknownSource)[:] at org.apache.xerces.impl.XMLErrorReporter.reportError(UnknownSource)[:] at org.apache.xerces.impl.XMLErrorReporter.reportError(UnknownSource)[:] at org.apache.xerces.impl.xs.XMLSchemaValidator$XSIErrorReporter.reportError(UnknownSource)[:] at org.apache.xerces.impl.xs.XMLSchemaValidator.reportSchemaError(UnknownSource)[:] at org.apache.xerces.impl.xs.XMLSchemaValidator.handleStartElement(UnknownSource)[:] at org.apache.xerces.impl.xs.XMLSchemaValidator.startElement(UnknownSource)[:] at org.apache.xerces.jaxp.validation.DOMValidatorHelper.beginNode(UnknownSource)[:] at org.apache.xerces.jaxp.validation.DOMValidatorHelper.validate(UnknownSource)[:] at org.apache.xerces.jaxp.validation.DOMValidatorHelper.validate(UnknownSource)[:] at org.apache.xerces.jaxp.validation.ValidatorImpl.validate(UnknownSource)[:] at javax.xml.validation.Validator.validate(Unknown Source)[:2.2.0] at org.apache.aries.blueprint.parser.Parser.validate(Parser.java:285)[7:org.apache.aries.blueprint.core:1.1.0] ... 23 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 7 months ago
    Unknown user
    2 times, 11 months ago
    Unknown user
    Once, 1 year ago
    7 times, 2 months ago
    2 times, 2 months ago
    47 more bugmates