org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via aries-dev by Jean-Baptiste Onofré (JIRA), 1 year ago
Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle io.fabric8.fabric-agent [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=io.fabric8.api)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
via hivmr.com by Unknown author, 1 year ago
Unresolved constraint in bundle io.fabric8.fabric-core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0)))
via redhat.com by Unknown author, 1 year ago
Unresolved constraint in bundle io.fabric8.fabric-core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=com.google.common.base)(version>=15.0.0)(!(version>=16.0.0)))
via Google Groups by tornado, 4 months ago
Unresolved constraint in bundle org.apache.felix.bundlerepository [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))
via Google Groups by Newonthesit, 4 months ago
Unresolved constraint in bundle org.apache.felix.bundlerepository [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
at java.lang.Thread.run(Thread.java:662)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
14 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.