org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))

aries-dev | Jean-Baptiste Onofré (JIRA) | 4 years ago
  1. 0

    [jira] [Created] (ARIES-1013) Aries JMX Core should extend its OSGi framework version range

    aries-dev | 4 years ago | Jean-Baptiste Onofré (JIRA)
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
  2. 0

    [jira] [Updated] (ARIES-1013) Aries JMX Core should extend its OSGi framework version range

    aries-dev | 4 years ago | Jean-Baptiste Onofré (JIRA)
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
  3. 0

    How to include a jar of dependency in an OSGi bundle using maven bundle plugin?

    Stack Overflow | 4 years ago | Rahul Bobhate
    org.osgi.framework.BundleException: Unresolved constraint in bundle com.ct.service.userService [205]: Unable to resolve 205.2: missing requirement [205.2] osgi.wiring.package; (osgi.wiring.package=org.apache.lucene.analysis)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    javax.servlet.http package in Apache Karaf 2.3.0

    Stack Overflow | 4 years ago | Paulius Matulionis
    org.osgi.framework.BundleException: Unresolved constraint in bundle com.groupgti.esb.purge [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package ; (osgi.wiring.package=com.groupgti.esb.cxf.interceptors) [caused by: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=jav ax.servlet.http)(version>=2.6.0)(!(version>=3.0.0)))]
  6. 0

    Loading ipojo Maven Bundle in Pax Exam Test

    Stack Overflow | 4 years ago | user1991839
    org.osgi.framework.BundleException: Unresolved constraint in bundle com.N.A [35]: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.ipojo)(version>=1.8.0))

  1. davidvanlaatum 2631 times, last 2 months ago
  2. davidvanlaatum 10 times, last 2 months ago
6 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    FrameworkStartLevelImpl.run
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
    3. org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
    4. org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
    4 frames
  3. Java RT
    Thread.run
    1. java.lang.Thread.run(Thread.java:662)
    1 frame