org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))

aries-dev | Jean-Baptiste Onofré (JIRA) | 4 years ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    [jira] [Created] (ARIES-1013) Aries JMX Core should extend its OSGi framework version range

    aries-dev | 4 years ago | Jean-Baptiste Onofré (JIRA)
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
  2. 0

    [jira] [Updated] (ARIES-1013) Aries JMX Core should extend its OSGi framework version range

    aries-dev | 4 years ago | Jean-Baptiste Onofré (JIRA)
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
  3. 0

    CR3 is broken, doesn't start with JRE 8

    GitHub | 3 years ago | pires
    org.osgi.framework.BundleException: Unresolved constraint in bundle gravia-runtime-osgi [58]: Unable to resolve 58.0: missing requirement [58.0] osgi.wiring.package; (osgi.wiring.package=org.jboss.gravia.resource) [caused by: Unable to resolve 57.0: missing requirement [57.0] osgi.wiring.package; (osgi.wiring.package=javax.management)]
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Unable to undeloy osgi if correct Activator is not specified

    GitHub | 3 years ago | wezell
    org.osgi.framework.BundleException: Unresolved constraint in bundle plugin-dotcms-actionlet-pushnow [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; (&(osgi.wiring.package=com.dotcms.plugin.email.osgi)(version>=0.0.0))
  6. 0

    Java 8 issue with Pax Exam chapter10-recipe-simple

    GitHub | 2 years ago | deklanowski
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)) [caused by: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]

  1. davidvanlaatum 2631 times, last 8 months ago
6 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    FrameworkStartLevelImpl.run
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
    3. org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1388)
    4. org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:301)
    4 frames
  3. Java RT
    Thread.run
    1. java.lang.Thread.run(Thread.java:662)
    1 frame