java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Build from trunk not loading JBI
    via by Scott Came,
  • Re: Build from trunk not loading JBI
    via by Jean-Baptiste Onofré,
  • Karaf 3.0.0-SNAPSHOT not works
    via by Guofeng Zhang,
  • Karaf 3.0.0-SNAPSHOT not works
    via by Guofeng Zhang,
  • openengsb fails during startup
    via by Christoph Prybila,
  • Plugin Loading Errors Starting JIRA | Elemecca
    via by Unknown author,
    • java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0))) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:326)[19:org.apache.karaf.features.core:2.1.3] at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:792)[19:org.apache.karaf.features.core:2.1.3] Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)[org.apache.felix.framework-3.0.2.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)[org.apache.felix.framework-3.0.2.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)[org.apache.felix.framework-3.0.2.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)[org.apache.felix.framework-3.0.2.jar:] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:323)[19:org.apache.karaf.features.core:2.1.3] ... 1 more

    Users with the same issue

    davidvanlaatum
    davidvanlaatum28 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    14 more bugmates