java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))

servicemix-users | Jean-Baptiste Onofré | 6 years ago
  1. 0

    Build from trunk not loading JBI

    servicemix-users | 6 years ago | Scott Came
    java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
  2. 0

    Re: Build from trunk not loading JBI

    servicemix-users | 6 years ago | Jean-Baptiste Onofré
    java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
  3. 0

    Karaf 3.0.0-SNAPSHOT not works

    karaf-user | 5 years ago | Guofeng Zhang
    java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Karaf 3.0.0-SNAPSHOT not works

    karaf-user | 5 years ago | Guofeng Zhang
    java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
  6. 0

    Unable to install and enable the plugin

    GitHub | 2 years ago | nmuldoon
    com.atlassian.plugin.PluginException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.everit.jira.worklog.query.plugin.itest [166]: Unable to resolve 166.0: missing requirement [166.0] package; (&(package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))

  1. davidvanlaatum 28 times, last 1 month ago
  2. davidvanlaatum 7 times, last 2 months ago
15 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))

    at org.apache.felix.framework.Felix.resolveBundle()
  2. Apache Felix Framework
    BundleImpl.start
    1. org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)[org.apache.felix.framework-3.0.2.jar:]
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1709)[org.apache.felix.framework-3.0.2.jar:]
    3. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)[org.apache.felix.framework-3.0.2.jar:]
    4. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)[org.apache.felix.framework-3.0.2.jar:]
    4 frames
  3. Pax Runner
    FeaturesServiceImpl$1.run
    1. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:323)[19:org.apache.karaf.features.core:2.1.3]
    2. org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:792)[19:org.apache.karaf.features.core:2.1.3]
    2 frames