java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))

servicemix-users | Scott Came | 6 years ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    RE: Build from trunk not loading JBI

    servicemix-users | 6 years ago | Scott Came
    java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
  2. 0

    Missing Constraint: Import-Package: org.apache.tools.ant; version="0.0.0

    GitHub | 2 years ago | patriknw
    java.lang.Exception: Could not start bundle mvn:org.scalatest/scalatest_2.11/2.2.3 in feature(s) exam-2.6.0: The bundle "org.scalatest_2.2.3 [72]" could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.tools.ant; version="0.0.0"
  3. 0

    osgi-dining-hakkers sample broken with scalatest 2.2.3

    GitHub | 2 years ago | patriknw
    java.lang.Exception: Could not start bundle mvn:org.scalatest/scalatest_2.11/2.2.3 in feature(s) exam-2.6.0: The bundle "org.scalatest_2.2.3 [72]" could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.tools.ant; version="0.0.0"
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    ServiceMix - User - [SMX 5.0.1] Unable to resolve bundle revision because it is exposed to package 'org.springframework.transaction' via two dependency chains

    nabble.com | 1 year ago
    java.lang.Exception: Could not start bundle mvn:com.test.data/datasource-service/1.0.0-SNAPSHOT in feature(s) datasource-service-1.0.0-SNAPSHOT: Uses constraint violation. Unable to resolve bundle revision com.test.data.datasource-service [213.0] because it is exposed to package 'org.springframework.transaction' from bundle revisions org.apache.servicemix.bundles.spring-tx [197.0] and org.springframework.transaction [105.0] via two dependency chains. Chain 1:   com.test.data.datasource-service [213.0]     import: (&(osgi.wiring.package=org.springframework.transaction)(version>=3.2.4.RELESE))      |     export: osgi.wiring.package=org.springframework.transaction   org.apache.servicemix.bundles.spring-tx [197.0] Chain 2:   com.test.data.datasource-service [213.0]     import: (osgi.wiring.package=org.apache.camel.osgi)      |     export: osgi.wiring.package=org.apache.camel.osgi; uses:=org.springframework.transaction   org.apache.camel.camel-spring [114.0]     import: (&(osgi.wiring.package=org.springframework.transaction)(version>=3.1.0)(!(version>=3.3.0)))      |     export: osgi.wiring.package=org.springframework.transaction   org.springframework.transaction [105.0]
  6. 0

    [Camel-dev] [jira] [Created] (CAMEL-4658) Camel 2.9.0 SNAPSHOT not start on OSGI apache karaf - Grokbase

    grokbase.com | 11 months ago
    java.lang.Exception: Could not start bundle mvn:org.apache.camel.karaf/camel-karaf-commands/2.9.0-SNAPSHOT in feature(s) camel-core-2.9.0-SNAPSHOT: Unresolve d constraint in bundle org.apache.camel.karaf.camel-karaf-commands [95]: Unable to resolve 95.0: missing requirement [95.0] package; (&(package=org.apache.fe lix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))

    Root Cause Analysis

    1. java.lang.Exception

      Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))

      at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures()
    2. Pax Runner
      FeaturesServiceImpl.installFeatures
      1. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:326)[19:org.apache.karaf.features.core:2.1.3]
      1 frame