java.lang.NoClassDefFoundError: org/xml/sax/EntityResolver > > Looks like this class is not imported by the bundle (it may be optionally > imported but not available at resolution time or dynamically imported and > not available or not imported at all and not available through boot class > delegation). > > You will have to check the configuration (Import-Package and > DynamicImport-Package manifest headers) and status of the respective bundle > to find out. > > To me this looks like a bug in the bundle manifest with a missing or > wrongly configured import statement for the org.xml.sax package. > > Regards > Felix >

felix-users | clement escoffier | 4 years ago
  1. 0

    Re: Error when start felix/ipojo dosgi

    felix-users | 4 years ago | clement escoffier
    java.lang.NoClassDefFoundError: org/xml/sax/EntityResolver > > Looks like this class is not imported by the bundle (it may be optionally > imported but not available at resolution time or dynamically imported and > not available or not imported at all and not available through boot class > delegation). > > You will have to check the configuration (Import-Package and > DynamicImport-Package manifest headers) and status of the respective bundle > to find out. > > To me this looks like a bug in the bundle manifest with a missing or > wrongly configured import statement for the org.xml.sax package. > > Regards > Felix >
  2. 0

    Problems with Guice in Eclipse: Class Loading Exceptions

    Google Groups | 8 years ago | Anne Martens
    java.lang.NoClassDefFoundError: com/google/ > >> inject/internal/collect/Lists > >>  at com.google.inject.multibindings.Multibinder > >> $RealMultibinder.initialize(Multibinder.java:254) > >>  at org.opt4j.start.Opt4JModule.multi(Opt4JModule.java:128) > > >> This was after I fixed a bug in my own code, which might be a reason > >> why you did not see it. I uploaded a fixed version of my code to the > >> url named above (http://sdqweb.ipd.uka.de/temp/org.opt4j-wrapper- > >> plugin.zip<http://sdqweb.ipd.uka.de/temp/org.opt4j-wrapper-%0Aplugin.zip> > >> ). > > >> Is it possible that the guice-multibindings-....jar also needs a > >> patch? Or is it a problem that multibindings resides in its own jar? > >> For the latter, it might be an option to join the two into one jar. > > > Note this is actually a different issue unrelated to the previous problem, > > the issue here is that the multibindings extension uses classes from the > > internal Guice package which (rightly) isn't exported > > > Seehttp://code.google.com/p/google-guice/issues/detail?id=311 > > > If you've got them inside the same Bundle-ClassPath (as you had before) > > then it shouldn't matter because the internal package is only hidden from > > other bundles / plug-in ... jars on the same Bundle-ClassPath will merge > > together just like in a classic Java application > > > however, if you're using them as separate bundles then you'd need to > > patch the multibindings jar to attach as a fragment to the Guice bundle > > as suggested in Issue 311 > > > I'll take a look at your updated code to see what's changed... > > Aha, found the problem - it's because the packaging of Google-Collection > classes inside Guice changed post-20090205... so when you use the old > multibindings jar with the new Guice jar there's a package mismatch. > > In the 20090205 snapshot it was "com.google.inject.internal.common.Lists", > now it is "com.google.inject.internal.Lists" - if you build Guice > multibindings > from trunk (or use the jar I'm going to send you) then everything should > work > > > Kind regards, > >> Anne > > >> On 3 Mrz., 18:51, Anne Martens <annema...@googlemail.com> wrote: > >> > Dear Stuart, > > >> > thanks a lot for your fast reply! Yes, I'm absolutely ok with using a > >> > patched version, I'm glad that there is a readily available solution. > > >> > I will try it and then let you know. > > >> > Kind regards > >> > from a very happy Anne > > >> > On 3 Mrz., 17:34, Stuart McCulloch <mcc...@gmail.com> wrote: > > >> > > 2009/3/3 Anne Martens <annema...@googlemail.com> > > >> > > > Dear Stuart, > > >> > > > I have uploaded to code to > >> > > >http://sdqweb.ipd.uka.de/temp/org.opt4j-wrapper-plugin.zip. > >> > > > You also find a .project file for Eclipse there. Currently, the > >> plugin > >> > > > needs org.eclipse.core.runtime for the plugin activator > >> > > > Opt4JPluginActivator, but you can delete the class and the > >> dependency > >> > > > if you do not use Eclipse. To get the error, please call > >> > > > de.uka.ipd.sdq.dsexplore.opt4j.start.Opt4JStarter.startOpt4J() > > >> > > Hi Anne, > > >> > > I tracked the exception down to a binding for a system type > >> > > (java.util.Random) > >> > > in the OPT4J codebase that requires a constructor proxy - Guice checks > >> with > >> > > the BytecodeGen utility class to decide whether it needs a bridge > >> > > classloader > >> > > and it decides it doesn't for a system type, as mentioned in the Guice > >> wiki: > > >> > >    http://code.google.com/p/google-guice/wiki/ClassLoading > > >> > > Unfortunately, the classloader then returned by BytecodeGen is not the > >> Guice > >> > > classloader but the system classloader. Of course this does not have > >> access > >> > > to the internal Guice AOP classes, and the injector blows up :( > > >> > > I tried changing the OPT4J code to avoid the constructor proxy, but I > >> > > couldn't > >> > > get round it without making major changes to the code, so you'll need > >> to use > >> > > a patched version of Guice (at least until this is fixed in trunk) > > >> > > A quick fix would be to remove the following check from > >> BytecodeGen.java: > > >> > >     if (delegate == getSystemClassLoaderOrNull()) { > >> > >       return delegate; > >> > >     } > > >> > > Which would then enable bridging for system types - another option > >> would be > >> > > to return the Guice class loader at this point instead of the system > >> > > classloader: > > >> > >     if (delegate == getSystemClassLoaderOrNull()) { > >> > >       return GUICE_CLASS_LOADER; > >> > >     } > > >> > > Either of these would solve your problem, but they are not complete > >> because > >> > > the Guice classloader won't have access to types in the system > >> classloader > >> > > that don't reside in the "java" namespace (such as javax.* / > >> org.omg.*) > >> > > unless > >> > > of course you enabled OSGi bootdelegation for these packages... > > >> > > I've coded up a solution that doesn't suffer from this and raised a > >> Guice > >> > > issue: > > >> > >    http://code.google.com/p/google-guice/issues/detail?id=343 > > >> > > You can download a patched version of Guice here: > > >> > >http://code.google.com/p/peaberry/source/browse/trunk/lib/build/guice. > >> .. > > >> > > which avoids the AOP exception. > > >> > > Not sure if this patch will make it into Guice 2 because it is in a > >> critical > >> > > piece > >> > > of code, and I don't want to put any undue pressure on Jesse who's > >> already > >> > > done a lot of testing with the current code. > > >> > > Are you ok using the patched build until this is fixed in an official > >> > > release? > > >> > > For configuration details, I also uploaded > > >> > > >http://sdqweb.ipd.uka.de/temp/eclipse-config.txt, > >> > > > which is a copy of the configuration details Eclipse provides > >> > > > in Help -> About Eclipse Platform. I currently use version: > >> 3.4.1build > >> > > > id: M20080911-1700. > > >> > > > Thanks a lot! If you need more information, please let me know. > > >> > > > Kind regards, > >> > > > Anne > > >> > > > On 2 Mrz., 15:22, Stuart McCulloch <mcc...@gmail.com> wrote: > >> > > > > 2009/3/2 Anne Martens <annema...@googlemail.com> > > >> > > > > > Dear Stuart, > > >> > > > > > thanks a lot for your help. > > >> > > > > > Indeed, I only need Guice within a single plugin/bundle. That's > >> why I > >> > > > > > now put the three guice jars (guice-snapshot, > >> guice-multibindings- > >> > > > > > snapshot and aopalliance) back into the "referenced libraries" > >> of my > >> > > > > > opt4j wrapper plugin. I also tried to move the code starting > >> Opt4J to > >> > > > > > a new plugin activator class, that is activated when OSGi loads > >> the > >> > > > > > bundle. > > >> > > > > > Still, I get the same error (with a different stacktrace, of > >> course): > > >> > > > > > com.google.inject.internal.ComputationException: > >> > > > > > com.google.inject.internal.ComputationException: > >> > > > > > com.google.inject.internal.ComputationException: > >> > > > > > com.google.inject.internal.ComputationException: > >> > > > > > com.google.inject.internal.cglib.core.CodeGenerationException: > >> > > > > > java.lang.reflect.InvocationTargetException-->null at > >> com.google.inject.internal.MapMaker$StrategyImpl.compute > >> > > > > > (MapMaker.java:538) at > >> com.google.inject.internal.MapMaker$StrategyImpl.compute > >> > > > > > (MapMaker.java:404) at com.google.inject.internal.CustomConcurrentHashMap > >> > > > > > $ComputingImpl.get(CustomConcurrentHashMap.java:2031) at > >> > > > com.google.inject.internal.FailableCache.get(FailableCache.java: > >> > > > > > 46) at > >> com.google.inject.InjectorImpl$LateBoundConstructor.bind > >> > > > > > (InjectorImpl.java:457) at com.google.inject.ClassBindingImpl.initialize > >> > > > > > (ClassBindingImpl.java:52) at > > >> com.google.inject.InjectorImpl.initializeBinding(InjectorImpl.java: > >> > > > > > 347) at com.google.inject.InjectorImpl.createJustInTimeBinding > >> > > > > > (InjectorImpl.java:639) at > >> > > > com.google.inject.InjectorImpl.createJustInTimeBindingRecursive > >> > > > > > (InjectorImpl.java:584) at com.google.inject.InjectorImpl.getJustInTimeBinding > >> > > > > > (InjectorImpl.java:179) at > > >> com.google.inject.InjectorImpl.getBindingOrThrow(InjectorImpl.java: > >> > > > > > 139) at com.google.inject.InjectorImpl.getInternalFactory > >> > > > > > (InjectorImpl.java:645) at > >> com.google.inject.FactoryProxy.notify(FactoryProxy.java:48) at > >> com.google.inject.BindingProcessor.runCreationListeners > >> > > > > > (BindingProcessor.java:215) at com.google.inject.InjectorBuilder.initializeStatically > >> > > > > > (InjectorBuilder.java:131) at > >> > > > com.google.inject.InjectorBuilder.build(InjectorBuilder.java:105)
  3. 0

    JBoss Community / Mailing Lists

    sourceforge.net | 1 year ago
    java.lang.NoClassDefFoundError: sun/tools/javac/Main > > RequestURI=/test/Jsp1.jsp > > When I try to run the servlet, I get the following: > > HTTP ERROR: 404 Not Found > > Could not find resource for /servlet1 > > RequestURI=/servlet1 > > My web.xml looks like this: > > <?xml version="1.0" encoding="UTF-8"?> > <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application > 2.2//EN" " ; > <web-app> > <servlet> > <servlet-name>servlet1</servlet-name> > <servlet-class>untitled1.Servlet1</servlet-class> > </servlet> > <servlet-mapping> > <servlet-name>servlet1</servlet-name> > <url-pattern>/servlet1</url-pattern> > </servlet-mapping> > </web-app> > > Why won't the jsp and servlet run? I'm used to working with Resin, and I > just drop them in and the container compiles them, no special magic needed. > Am I missing something here? > > Thanks much, > Brian > > -----Original Message----- > From: jboss-user-admin@... > [mailto:jboss-user-admin@...]On Behalf Of Julian > Gosnell > Sent: Monday, July 09, 2001 8:21 PM > To: jboss-user@... > Subject: Re: [JBoss-user] Adding web app to Jetty...pls help. > > > I've just reread my mail.... > > Ignore the bit 'should be posted....'. There is a lot of reference to EARS > and > JBoss, so this is completely relevant. > > When I started writing it I was only going to talk about the Jetty config > file. > Then I took a step back, thought about EAR files and rethought my answer. > > Jules > > > Julian Gosnell wrote: > > > "Brian D. Brown" wrote: > > > > > I have a question which should be simple to answer. I am trying to add > a > > > new web app to jetty, but I don't understand how to do it. Is there > some > > > automated mechanism to deploy the app, or do I have to edit some config > file > > > or something? Please explain how to do this with and without using > virtual > > > hosting. > > > > > > Thanks in advance. > > > > > > Brian > > > > Firstly, this should be posted to jetty-discuss@... - being a > Jetty > > and not a Jboss question :-), but seeing as it's here, and it's bound to > be > > asked again..... > > > > Is the webapp going to talk to EJBs ? > > > > Yes - stick it in a ear and deploy via JBoss, either by copying it into > > jboss/deploy (a hot-deploy) or via the JMX interface to the J2EEDeployer > > (available on port 8082). The J2EEDeployer must be in charge, otherwise it > > cannot coordinate the deployment of EJBs and WebApp - this means that they > > won't share a common ClassLoader and this means that all calls between > them > > will result in serialisation and will not be optimised down to standard > > function calls. > > > > No - You could still stick it in an ear and deploy it via JBoss, or you > can put > > an entry into Jetty's config file - currently defaults to > > jboss/conf/jetty/jetty.xml - this is the demo config. you need to insert > > another entry that looks like this : > > > > <Call name="addWebApplication"> > > <Arg>/jetty/*</Arg> > > <Arg><SystemProperty name="jetty.home" > default="."/>/webapps/jetty</Arg> > > <Arg><SystemProperty name="jetty.home" > > default="."/>/etc/webdefault.xml</Arg> > > <Arg type="boolean">false</Arg> > > </Call> > > > > This translates into the Java : > > > > jetty.addWebApplication("/jetty/*", System.getProperty("jetty.home", > > ".")+"/webapps/jetty", System.getProperty("jetty.home", > > ".")+"/etc/default.xml", false); > > > > the args mean : > > > > 1 - the URL you want the webapp to deploy to - e.g. localhost:8080:/jetty > > 2 - where to find the webapp (in this case a dir, but could be a war - > i.e. end > > in war) > > 3 - where to find the webdefault.xml - default bindings for webapps - just > copy > > this - look in the file if you are interested > > 4 - whether to unpack the webapp (if it is a war) before running it - JSPs > will > > fail to compile if this is set to false and you deploy an archive > > > > If you don't understand XML - then you are taking your life into your > hands > > going this route. > > > > That's as clear as it gets ! > > > > Jules > > > > _________________________________________________________ > > Do You Yahoo!? > > Get your free @yahoo.com address at > > > > _______________________________________________ > > JBoss-user mailing list > > JBoss-user@... > > > > > _________________________________________________________ > Do You Yahoo!? > Get your free @yahoo.com address at > > > _______________________________________________ > JBoss-user mailing list > JBoss-user@... > > > > _______________________________________________ > JBoss-user mailing list > JBoss-user@... > _______________________________________________ JBoss-user mailing list JBoss-user@... --__--__-- Message: 2 Date: Tue, 10 Jul 2001 14:06:57 -0300 To: jboss-user@... From: Emerson <emerson@...> Subject: [JBoss-user] reloading classes Reply-To: jboss-user@... I made a system that depending on the pathInfo calls a diferent comand class (command design pattern). The problem is that the class is not reloaded when I change it, is there any manner to accomplish that? Emerson Cargnin TRE-SC Setor de Desenvolvimento Tel: (48) 251-3700 - Ramal 3134 --__--__-- Message: 3 Date: Tue, 10 Jul 2001 13:16:47 -0400 From: Stewart Allen <stewart@...> To: jboss-user@... Subject: Re: [JBoss-user] running JBoss inside another app Reply-To: jboss-user@... Thanks for the response, Marc. I have proceeded to the point where, with the default settings, everything boots up until the InstantDB blocks on a pool call. At this point, JBoss is frozen. The log tail looks like this: [Hypersonic] Started [InstantDB] Starting [InstantDB] XA Connection pool InstantDB bound to java:/InstantDB Enhydra InstantDB - Version 3.26 [InstantDB] The Initial Developer of the Original Code is Lutris Technologies Inc. Portions created by Lutris are Copyright (C) 1997-2001 Lutris Technologies, Inc. All Rights Reserved. [Hypersonic] Server 1.4 is running [Hypersonic] Press [Ctrl]+[C] to abort ...frozen at this point the traceback for the blocking call is: "main" (TID:0x403487e0, sys_thread_t:0x804fc10, state:CW, native ID:0x400) prio=5
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.NoClassDefFoundError

      org/xml/sax/EntityResolver > > Looks like this class is not imported by the bundle (it may be optionally > imported but not available at resolution time or dynamically imported and > not available or not imported at all and not available through boot class > delegation). > > You will have to check the configuration (Import-Package and > DynamicImport-Package manifest headers) and status of the respective bundle > to find out. > > To me this looks like a bug in the bundle manifest with a missing or > wrongly configured import statement for the org.xml.sax package. > > Regards > Felix >

      at org.apache.cxf.dosgi.dsw.OsgiUtils.readIntentMap()
    2. org.apache.cxf
      Activator.getIntentMap
      1. org.apache.cxf.dosgi.dsw.OsgiUtils.readIntentMap(OsgiUtils.java:418)
      2. org.apache.cxf.dosgi.dsw.OsgiUtils.getIntentMap(OsgiUtils.java:397)
      3. org.apache.cxf.dosgi.dsw.Activator.getIntentMap(Activator.java:109)
      3 frames