org.osgi.framework.BundleException

Unresolved constraint in bundle com.sun.enterprise.osgi-adapter [256]: Unable to resolve 256.0: missing requirement [256.0] package; (&(package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 170.0: missing requirement [170.0] package; (&(package=org.jvnet.hk2.config)(version>=1.1.0)) [caused by: Unable to resolve 55.0: missing requirement [55.0] package; (package=javax.management)]]

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web6407

  • Unresolved constraint in bundle com.sun.enterprise.osgi-adapter [256]: Unable to resolve 256.0: missing requirement [256.0] package; (&(package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 170.0: missing requirement
  • Unresolved constraint in bundle com.sun.enterprise.osgi-adapter [256]: Unable to resolve 256.0: missing requirement [256.0] package; (&(package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 170.0: missing requirement
  • via JDK Bug System by Webbug Group, 1 year ago
    Unresolved constraint in bundle com.sun.enterprise.osgi-adapter [199]: Unable to resolve 199.0: missing requirement [199.0] package; (&(package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to re solve 122.0: missing requirement
  • Stack trace

    • org.osgi.framework.BundleException: Unresolved constraint in bundle com.sun.enterprise.osgi-adapter [256]: Unable to resolve 256.0: missing requirement [256.0] package; (&(package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 170.0: missing requirement [170.0] package; (&(package=org.jvnet.hk2.config)(version>=1.1.0)) [caused by: Unable to resolve 55.0: missing requirement [55.0] package; (package=javax.management)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3443) at org.apache.felix.framework.Felix.startBundle(Felix.java:1727) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1156) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:722)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 5 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 11 months ago
    2 more bugmates