java.lang.reflect.InvocationTargetException

tip

Java does not handle IPv6 nameservers before 1.8.0_60. Upgrade to the latest JVM.


rp
tip

This is a bug in Wise, updating to v4.10 seems to solve the problem.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Re: Yarn 2.7.1
    via by Kristoffer Sjögren,
  • Re: Yarn 2.7.1
    via by Terence Yim,
  • Re: Yarn 2.7.1
    via by Kristoffer Sjögren,
  • Re: Yarn 2.7.1
    via by Terence Yim,
  • Re: Yarn 2.7.1
    via by Kristoffer Sjögren,
  • Re: Yarn 2.7.1
    via by Kristoffer Sjögren,
  • Re: Yarn 2.7.1
    via by Terence Yim,
  • Re: Yarn 2.7.1
    via by Kristoffer Sjögren,
  • Re: Yarn 2.7.1
    via by Terence Yim,
  • Re: Yarn 2.7.1
    via by Kristoffer Sjögren,
    • java.lang.reflect.InvocationTargetException at com.google.common.base.Throwables.propagate(Throwables.java:160) at org.apache.twill.internal.yarn.VersionDetectYarnAMClientFactory.create(VersionDetectYarnAMClientFactory.java:61) at org.apache.twill.internal.appmaster.ApplicationMasterMain.main(ApplicationMasterMain.java:77) Caused by: java.lang.reflect.InvocationTargetException at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:422) at org.apache.twill.internal.yarn.VersionDetectYarnAMClientFactory.create(VersionDetectYarnAMClientFactory.java:58) ... 3 more Caused by: java.lang.IllegalArgumentException: Invalid ContainerId: container_e25_1453466340022_0004_01_000001 at org.apache.hadoop.yarn.util.ConverterUtils.toContainerId(ConverterUtils.java:182) at org.apache.twill.internal.yarn.AbstractYarnAMClient.<init>(AbstractYarnAMClient.java:83) at org.apache.twill.internal.yarn.Hadoop21YarnAMClient.<init>(Hadoop21YarnAMClient.java:65) at org.apache.twill.internal.yarn.Hadoop22YarnAMClient.<init>(Hadoop22YarnAMClient.java:34) ... 8 more Caused by: java.lang.NumberFormatException: For input string: "e25" at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65) at java.lang.Long.parseLong(Long.java:589) at java.lang.Long.parseLong(Long.java:631) at org.apache.hadoop.yarn.util.ConverterUtils.toApplicationAttemptId(ConverterUtils.java:137) at org.apache.hadoop.yarn.util.ConverterUtils.toContainerId(ConverterUtils.java:177) ... 12 more

    Users with the same issue

    Unknown visitor2 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Luka
    2 times, last one,
    tvrmsmith
    1 times, last one,
    201 more bugmates