org.jboss.netty.channel.ChannelException

Failed to bind to: 0.0.0.0/0.0.0.0:6703

Samebug tips3

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web212

  • via incubator-storm-dev by researcher cs, 9 months ago
    Failed to bind to: 0.0.0.0/0.0.0.0:6703
  • via storm-user by researcher cs, 2 weeks ago
    Failed to bind to: 0.0.0.0/0.0.0.0:6703
  • via incubator-storm-user by researcher cs, 2 weeks ago
    Failed to bind to: 0.0.0.0/0.0.0.0:6703
  • Stack trace

    • org.jboss.netty.channel.ChannelException: Failed to bind to: 0.0.0.0/0.0.0.0:6703 at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:272)[netty-3.6.3.Final.jar:na] at backtype.storm.messaging.netty.Server.<init>(Server.java:56)[storm-netty-0.9.0.1.jar:na] at backtype.storm.messaging.netty.Context.bind(Context.java:27)[storm-netty-0.9.0.1.jar:na] at backtype.storm.messaging.loader$launch_receive_thread_BANG_$fn__2984.invoke(loader.clj:20)[storm-core-0.9.0.1.jar:na] at backtype.storm.util$async_loop$fn__444.invoke(util.clj:401)[storm-core-0.9.0.1.jar:na] at clojure.lang.AFn.run(AFn.java:24)[clojure-1.4.0.jar:na] at java.lang.Thread.run(Thread.java:701)[na:1.6.0_37] Caused by: java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method)[na:1.6.0_37] at sun.nio.ch.Net.bind(Net.java:174)[na:1.6.0_37] at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:139)[na:1.6.0_37] at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)[na:1.6.0_37] at org.jboss.netty.channel.socket.nio.NioServerBoss$RegisterTask.run(NioServerBoss.java:193)[netty-3.6.3.Final.jar:na] at org.jboss.netty.channel.socket.nio.AbstractNioSelector.processTaskQueue(AbstractNioSelector.java:366)[netty-3.6.3.Final.jar:na] at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:290)[netty-3.6.3.Final.jar:na] at org.jboss.netty.channel.socket.nio.NioServerBoss.run(NioServerBoss.java:42)[netty-3.6.3.Final.jar:na] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)[na:1.6.0_37] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[na:1.6.0_37] ... 1 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    57 times, 8 months ago
    Unknown user
    Once, 1 year ago
    Once, 2 weeks ago
    Unknown user
    Once, 1 year ago
    Once, 21 hours ago
    142 more bugmates