java.lang.NoClassDefFoundError

org/antlr/runtime/RecognitionException

Samebug tips8

You might've forgot to add a dependency or it's written wrong. Also, you might be using incompatible versions of Java and Hibernate. More on this here: https://goo.gl/SjSlRA


rafaelrafael

jsp-api and servlet-api jars must NOT be deployed by your web app. They should be marked as provided but not deployed by your app.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Stack trace

  • java.lang.NoClassDefFoundError: org/antlr/runtime/RecognitionException at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Class.java:2521) at java.lang.Class.getMethod0(Class.java:2764) at java.lang.Class.getMethod(Class.java:1653) at org.apache.hadoop.util.RunJar.main(RunJar.java:150) Caused by: java.lang.ClassNotFoundException: org.antlr.runtime.RecognitionException at java.net.URLClassLoader$1.run(URLClassLoader.java:366) at java.net.URLClassLoader$1.run(URLClassLoader.java:355) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:354) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ... 5 more

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Unknown visitor
Unknown visitorOnce,
oddodd
Once,
poroszdporoszd
Once,
andyglickandyglick
2 times, last one
tzrlktzrlk
5 times, last one
1203 more bugmates