java.security.InvalidKeyException: Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)

xml-security-dev | Peter Hendry | 10 years ago
  1. 0

    text.xml.security.devel - Re: Issue moving from JDK 1.4 to 1.5 - msg#00006 - Recent Discussion OSDir.com

    osdir.com | 1 year ago
    java.security.InvalidKeyException: Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)
  2. 0

    Re: Issue moving from JDK 1.4 to 1.5

    xml-security-dev | 10 years ago | Peter Hendry
    java.security.InvalidKeyException: Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)
  3. 0

    Re: Issue moving from JDK 1.4 to 1.5

    xml-security-dev | 10 years ago | Peter Hendry
    java.security.InvalidKeyException: Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Re: Issue moving from JDK 1.4 to 1.5

    xml-security-dev | 10 years ago | Peter Hendry
    java.security.InvalidKeyException: Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)
  6. 0

    Re: Issue moving from JDK 1.4 to 1.5

    xml-security-dev | 10 years ago | Peter Hendry
    java.security.InvalidKeyException: Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.security.InvalidKeyException

      Wrong algorithm: DESede or TripleDES required at org.apache.xml.security.encryption.XMLCipher.decryptToByteArray(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.decryptElement(Unknown Source) at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source) at com.capeclear.pgh.stuff.SecurityKeyTests.main(SecurityKeyTests.java:98)

      at sun.reflect.NativeMethodAccessorImpl.invoke0()
    2. Java RT
      NativeMethodAccessorImpl.invoke0
      1. sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      1 frame