java.lang.NoClassDefFoundError

Test (wrong name: a/b/Test)

Samebug tips1

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web2117

  • via Coderanch by Abhay Agarwal, 9 months ago
    Test (wrong name: a/b/Test)
  • via Oracle Community by 807593, 11 months ago
    IUBanque (wrong name: test/IUBanque)[b/]
  • via Google Groups by yawnmoth, 1 year ago
    Test (wrong name: test)
  • Stack trace

    • java.lang.NoClassDefFoundError: Test (wrong name: a/b/Test) at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 1 year ago
    Unknown user
    2 times, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Once, 18 hours ago
    165 more bugmates