org.eclipse.aether.transfer.ArtifactTransferException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Re: Deploy URL for "internal" repository
    via by Bk Lau,
  • Re: Deploy URL for "internal" repository
    via by Bk Lau,
  • GitHub comment 5650#180434789
    via GitHub by TobiasOtto
    ,
  • GitHub comment 4363#152851103
    via GitHub by dbl001
    ,
  • GitHub comment 4363#152852647
    via GitHub by dbl001
    ,
  • GitHub comment 4363#152852865
    via GitHub by dbl001
    ,
  • GitHub comment 8050#138283684
    via GitHub by wildfly-ci
    ,
  • grailsw fails behind a proxy
    via GitHub by hanafey
    ,
    • org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact org.something rom/to External-Repo (http://localhost:9080/repository/internal): Bad Request (400) at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:43) at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355) at org.eclipse.aether.connector.basic.BasicRepositoryConnector.put(BasicRepositoryConnector.java:274) at org.eclipse.aether.internal.impl.DefaultDeployer.deploy(DefaultDeployer.java:335) at org.eclipse.aether.internal.impl.DefaultDeployer.deploy(DefaultDeployer.java:269) at org.eclipse.aether.internal.impl.DefaultRepositorySystem.deploy(DefaultRepositorySystem.java:434)
    No Bugmate found.