java.net.SocketException

Relais brisé (pipe)

Samebug tips13

Probably there is a bug in TestNG Eclipse plugin (6.8.6.20130607_0745), try an other version (e.g. 6.8.0.20121120_1820)

before running my test in debug mode, i open the debug view, and remove some breakpoints (such as some remaining on NullPointersExceptions, and Sockets)

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web1574

  • via commons-user by Jean-Marc Spaggiari, 9 months ago
    Relais brisé (pipe)
  • via cxf-users by mystro7200, 11 months ago
    Relais brisé (pipe)
  • Relais brisé (pipe)
  • Stack trace

    • java.net.SocketException: Relais brisé (pipe) at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:109) at java.net.SocketOutputStream.write(SocketOutputStream.java:153) at java.io.ObjectOutputStream$BlockDataOutputStream.drain(ObjectOutputStream.java:1857) at java.io.ObjectOutputStream$BlockDataOutputStream.setBlockDataMode(ObjectOutputStream.java:1766) at java.io.ObjectOutputStream.writeNonProxyDesc(ObjectOutputStream.java:1273) at java.io.ObjectOutputStream.writeClassDesc(ObjectOutputStream.java:1227) at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1411) at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174) at java.io.ObjectOutputStream.writeFatalException(ObjectOutputStream.java:1557) at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:349) at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPSender.send(LateralTCPSender.java:222) at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPService.update(LateralTCPService.java:127) at org.apache.jcs.auxiliary.lateral.LateralCache.update(LateralCache.java:100) at org.apache.jcs.engine.CacheAdaptor.handlePut(CacheAdaptor.java:91) at org.apache.jcs.engine.CacheEventQueue$PutEvent.doRun(CacheEventQueue.java:688) at org.apache.jcs.engine.CacheEventQueue$AbstractCacheEvent.run(CacheEventQueue.java:607) at org.apache.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:575)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    2 times, 1 year ago
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    233 more bugmates