org.eclipse.aether.transfer.ArtifactTransferException

Could not transfer artifact org.apache.maven.wagon:wagon-ftp-2.8:jar:2.8-20150505.015103-2 from/to snapshots (http://localhost:8080/repository/snapshots): Bad Request (400)

Solutions on the web233

  • via archiva-users by Agung Dyanjatmiko, 9 months ago
    Could not transfer artifact org.apache.maven.wagon:wagon-ftp-2.8:jar:2.8-20150505.015103-2 from/to snapshots (http://localhost:8080/repository/snapshots): Bad Request (400)
  • via archiva-users by Agung Dyanjatmiko, 1 year ago
    Could not transfer artifact org.apache.maven.wagon:wagon-ftp-2.8:jar:2.8-20150505.015103-2 from/to snapshots (http://localhost:8080/repository/snapshots): Bad Request (400)
  • via gmane.org by Unknown author, 1 year ago
    Could not transfer artifact org.apache.maven.wagon:wagon-ftp-2.8:jar:2.8-20150505.015103-2 from/to snapshots ( Bad Request (400) at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:43) at
  • Stack trace

    • org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact org.apache.maven.wagon:wagon-ftp-2.8:jar:2.8-20150505.015103-2 from/to snapshots (http://localhost:8080/repository/snapshots): Bad Request (400) at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:43) at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355) at org.eclipse.aether.connector.basic.BasicRepositoryConnector.put(BasicRepositoryConnector.java:274) at org.eclipse.aether.internal.impl.DefaultDeployer.deploy(DefaultDeployer.java:311) at org.eclipse.aether.internal.impl.DefaultDeployer.deploy(DefaultDeployer.java:245) at org.eclipse.aether.internal.impl.DefaultRepositorySystem.deploy(DefaultRepositorySystem.java:413) at org.eclipse.aether.examples.DeployArtifacts.main(DeployArtifacts.java:69) Caused by: org.apache.http.client.HttpResponseException: Bad Request (400) at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:458) at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:283) at org.eclipse.aether.transport.http.HttpTransporter.implPut(HttpTransporter.java:257) at org.eclipse.aether.spi.connector.transport.AbstractTransporter.put(AbstractTransporter.java:117) at org.eclipse.aether.connector.basic.BasicRepositoryConnector$PutTaskRunner.runTask(BasicRepositoryConnector.java:510) at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:350)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago