java.lang.NoClassDefFoundError

tip

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • cannot run my java code after using Ant
    via by Stanley Walker,
  • New to GWT
    via by SBTECH,
  • newbie: cannot execute HelloWorld
    via by R.A.M.,
  • New to GWT
    via by SBTECH,
  • Package Problems
    via by Alex,
    • java.lang.NoClassDefFoundError: RunApplication (wrong name: common/RunApplication) at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.access$100(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source)

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    junior_cEngineerjunior_cEngineer
    1 times, last one,
    GhostsGhosts
    12 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    139 more bugmates