org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: javax. servlet.jsp; version="0.0.0" 72 org.apache.tuscany.sca.host.http ACTIVE

tuscany-user | Tom Leung | 4 years ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    Fail to run "calculator-bundle" from the OSGi demo "distributed-osgi-static" with Equinox Framework

    tuscany-user | 4 years ago | Tom Leung
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: javax. servlet.jsp; version="0.0.0" 72 org.apache.tuscany.sca.host.http ACTIVE
  2. 0

    Fail to run "calculator-bundle" from the OSGi demo "distributed-osgi-static" with Equinox Framework

    tuscany-user | 4 years ago | Tom Leung
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: javax. servlet.jsp; version="0.0.0" 72 org.apache.tuscany.sca.host.http ACTIVE
  3. 0

    Rodin Platform 1.2 Release Notes - Event-B

    event-b.org | 1 year ago
    org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Package uses conflict: Import-Package: org.apache.axis2.transport.http deploying web service in Geronimo with httpclient bundle installed

    Stack Overflow | 2 years ago | Caeiro
    org.osgi.framework.BundleException: The bundle "default.ConsultarProductosWebServer_1.0.0 [388]" could not be resolved. Reason: <strong>Package uses conflict: Import-Package: org.apache.axis2.transport.http; version="[1.6.1,1.6.1]", Package uses conflict: Import-Package: org.apache.axis2.transport.http.server; version="[1.6.1,1.6.1]"</strong>
  6. 0

    simple hello world bundle (osgi) fails

    Stack Overflow | 6 years ago | July
    org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.jsp.jasper_1.0.300.v20110502 [37]" could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.jasper.servlet; version="[0.0.0,6.0.0)"

    1 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      The bundle could not be resolved. Reason: Missing Constraint: Import-Package: javax. servlet.jsp; version="0.0.0" 72 org.apache.tuscany.sca.host.http ACTIVE

      at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError()
    2. Eclipse OSGi
      AbstractBundle.getResolverError
      1. org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1313)
      1 frame