org.apache.maven.lifecycle.LifecycleExecutionException

Missing: ---------- 1) org.apache.geronimo.bundles:axis:jar:1.4_1-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id] Path to dependency: 1) org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT 2) org.apache.geronimo.bundles:axis:jar:1.4_1-SNAPSHOT ---------- 1 required artifact is missing. for artifact: org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT from the specified remote repositories: codehaus.snapshots (http://snapshots.repository.codehaus.org), ibiblio.org (http://repo2.maven.org/maven2), ops4j.snapshots (http://repository.ops4j.org/mvn-snapshots/), apache.snapshots (http://repository.apache.org/snapshots)

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web4823

  • via geronimo-dev by gawor@apache.org, 9 months ago
    ---------- 1 required artifact is missing. for artifact: org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT from the specified remote repositories: ops4j.snapshots (http://repository.ops4j.org/mvn-snapshots/), apache.snapshots (http://repository.apache.org/snapshots), codehaus.snapshots (http://snapshots.repository.codehaus.org), ibiblio.org (http://repo2.maven.org/maven2)
  • via geronimo-dev by gawor@apache.org, 1 year ago
    ---------- 1 required artifact is missing. for artifact: org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT from the specified remote repositories: ops4j.snapshots (http://repository.ops4j.org/mvn-snapshots/), apache.snapshots (http://repository.apache.org/snapshots), codehaus.snapshots (http://snapshots.repository.codehaus.org), ibiblio.org (http://repo2.maven.org/maven2)
  • via geronimo-dev by gawor@apache.org, 1 year ago
    -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis
  • Stack trace

    • org.apache.maven.lifecycle.LifecycleExecutionException: Missing: ---------- 1) org.apache.geronimo.bundles:axis:jar:1.4_1-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id] Path to dependency: 1) org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT 2) org.apache.geronimo.bundles:axis:jar:1.4_1-SNAPSHOT ---------- 1 required artifact is missing. for artifact: org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT from the specified remote repositories: codehaus.snapshots (http://snapshots.repository.codehaus.org), ibiblio.org (http://repo2.maven.org/maven2), ops4j.snapshots (http://repository.ops4j.org/mvn-snapshots/), apache.snapshots (http://repository.apache.org/snapshots) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:711) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138) at org.apache.maven.cli.MavenCli.main(MavenCli.java:362) at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37) at java.lang.reflect.Method.invoke(Method.java:599) at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315) at org.codehaus.classworlds.Launcher.launch(Launcher.java:255) at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430) at org.codehaus.classworlds.Launcher.main(Launcher.java:375) Caused by: org.apache.maven.artifact.resolver.MultipleArtifactsNotFoundException: Missing: ---------- 1) org.apache.geronimo.bundles:axis:jar:1.4_1-SNAPSHOT Try downloading the file manually from the project website. Then, install it using the command: mvn install:install-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.apache.geronimo.bundles -DartifactId=axis -Dversion=1.4_1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id] Path to dependency: 1) org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT 2) org.apache.geronimo.bundles:axis:jar:1.4_1-SNAPSHOT ---------- 1 required artifact is missing. for artifact: org.apache.geronimo.modules:geronimo-webservices:bundle:3.0-SNAPSHOT from the specified remote repositories: codehaus.snapshots (http://snapshots.repository.codehaus.org), ibiblio.org (http://repo2.maven.org/maven2), ops4j.snapshots (http://repository.ops4j.org/mvn-snapshots/), apache.snapshots (http://repository.apache.org/snapshots) at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:360) at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:304) at org.apache.maven.plugin.DefaultPluginManager.resolveTransitiveDependencies(DefaultPluginManager.java:1499) at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:442) at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694) ... 17 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.