rg.osgi.framework.BundleException

Unresolved constraint in bundle CamelContext.xml [249]: Unable to resolve 249.1: missing requirement [249.1] osgi.wiring.package; (osgi.wiring.package=com.test.core)

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web5

  • via servicemix-users by fxthomas, 9 months ago
    Unresolved constraint in bundle CamelContext.xml [249]: Unable to resolve 249.1: missing requirement [249.1] osgi.wiring.package; (osgi.wiring.package=com.test.core)
  • via servicemix-users by fxthomas, 1 year ago
    Unresolved constraint in bundle CamelContext.xml [249]: Unable to resolve 249.1: missing requirement [249.1] osgi.wiring.package; (osgi.wiring.package=com.test.core)
  • via servicemix-users by fxthomas, 9 months ago
    Unresolved constraint in bundle CamelContext.xml [249]: Unable to resolve 249.1: missing requirement [249.1] osgi.wiring.package; (osgi.wiring.package=com.test.core)
  • Stack trace

    • rg.osgi.framework.BundleException: Unresolved constraint in bundle CamelContext.xml [249]: Unable to resolve 249.1: missing requirement [249.1] osgi.wiring.package; (osgi.wiring.package=com.test.core) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.