java.lang.IllegalStateException: Can't install feature camel-spring-redis/0.0.0: Can not resolve feature: Unsatisfied requirement(s): --------------------------- package:(&(package=org.springframework.data.redis.connection.jedis)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.core.io.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cache.transaction)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.env)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.data.redis.connection)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.core.serializer.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.aop.framework)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.convert.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.io)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.data.redis.core)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.util.xml)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.transaction.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cglib.proxy)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans.factory.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cache)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans.factory)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.dao.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans.factory.xml)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.dao)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.data.redis.core.query)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.data.redis.listener)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.data.redis.serializer)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.beans.factory.config)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.convert)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.context)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cache.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.task)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.util)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.convert.converter)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • GitHub comment 77#192254694
    via GitHub by ElisaRojas
    ,
  • GitHub comment 77#202895443
    via GitHub by ralvarep
    ,
  • Occasionally the events that trigger loading of required applications for the openflow meta app get delivered out of order, and apps that are required are loaded after the meta app. Here is an example stack trace: 2016-08-10 22:21:44,178 | WARN | -message-handler | ApplicationManager | 76 - org.onosproject.onos-core-net - 1.7.0.SNAPSHOT | Unable to perform operation on application org.onosproject.openflow-base java.lang.IllegalStateException: Can't install feature onos-providers-openflow-base/0.0.0: Could not start bundle mvn:org.onosproject/onos-providers-openflow-device/1.7.0-SNAPSHOT in feature(s) onos-providers-openflow-base-1.7.0-SNAPSHOT: Unresolved constraint in bundle org.onosproject.onos-providers-openflow-device [163]: Unable to resolve 163.0: missing requirement [163.0] osgi.wiring.package; (&(osgi.wiring.package=org.onosproject.net.optical.device)(version>=1.7.0)(!(version>=2.0.0))) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:405) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:373) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:351) at Proxy2f5c7ac0_3d59_4dae_bba3_203c1f78f885.installFeature(Unknown Source) at org.onosproject.app.impl.ApplicationManager.installAppFeatures(ApplicationManager.java:283) at org.onosproject.app.impl.ApplicationManager.access$200(ApplicationManager.java:66) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:210) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:202) at org.onosproject.store.app.DistributedApplicationStore.setupApplicationAndNotify(DistributedApplicationStore.java:484)[78:org.onosproject.onos-core-dist:1.7.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore.access$500(DistributedApplicationStore.java:94)[78:org.onosproject.onos-core-dist:1.7.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore$InternalAppsListener.event(DistributedApplicationStore.java:467) at org.onosproject.store.primitives.impl.MeteredAsyncConsistentMap$InternalMeteredMapEventListener.event(MeteredAsyncConsistentMap.java:291) at org.onosproject.store.primitives.impl.TranscodingAsyncConsistentMap$InternalBackingMapEventListener.event(TranscodingAsyncConsistentMap.java:311) at org.onosproject.store.primitives.resources.impl.AtomixConsistentMap.lambda$null$2(AtomixConsistentMap.java:102) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101] at java.lang.Thread.run(Thread.java:745)[:1.8.0_101]
    via by Ray Milkey,
  • The SNMP app will not start up due to unsatisfied dependencies. 2016-10-26 18:11:50,227 | WARN | -message-handler | ApplicationManager | 76 - org.onosproject.onos-core-net - 1.8.0.SNAPSHOT | Unable to perform operation on application org.onosproject.snmp java.lang.IllegalStateException: Can't install feature onos-snmp-app/0.0.0: Could not start bundle mvn:org.onosproject/mibbler-mibs-bti7000/1.0-20151221.1 in feature(s) onos-snmp-app-1.8.0-SNAPSHOT: Unresolved constraint in bundle bti7000 [198]: Unable to resolve 198.0: missing requirement [198.0] osgi.wiring.package; (&(osgi.wiring.package=com.btisystems.mibbler.mibs.netsnmp.netsnmp.mib_2)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 199.0: missing requirement [199.0] osgi.wiring.package; (&(osgi.wiring.package=com.btisystems.mibbler.mibs.rfc.rfc.mib_2.dot1dbridge)(version>=1.0.0)(!(version>=2.0.0)))] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:405) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:373) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:351) at Proxy36efcf9e_5686_4119_bc3c_d8b04a5fc626.installFeature(Unknown Source) at org.onosproject.app.impl.ApplicationManager.installAppFeatures(ApplicationManager.java:277) at org.onosproject.app.impl.ApplicationManager.access$200(ApplicationManager.java:66) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:204) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:196) at org.onosproject.store.AbstractStore.notifyDelegate(AbstractStore.java:58)[74:org.onosproject.onos-api:1.8.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore.access$500(DistributedApplicationStore.java:95)[78:org.onosproject.onos-core-dist:1.8.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore$AppActivator.accept(DistributedApplicationStore.java:439)[78:org.onosproject.onos-core-dist:1.8.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore$AppActivator.accept(DistributedApplicationStore.java:433)[78:org.onosproject.onos-core-dist:1.8.0.SNAPSHOT] at org.onosproject.store.primitives.impl.DefaultDistributedTopic.lambda$null$0(DefaultDistributedTopic.java:67) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101] at java.lang.Thread.run(Thread.java:745)[:1.8.0_101]
    via by Ray Milkey,
    • java.lang.IllegalStateException: Can't install feature camel-spring-redis/0.0.0: Can not resolve feature: Unsatisfied requirement(s): --------------------------- package:(&(package=org.springframework.data.redis.connection.jedis)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.core.io.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cache.transaction)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.env)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.data.redis.connection)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.core.serializer.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.aop.framework)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.convert.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.io)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.data.redis.core)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.util.xml)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.transaction.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cglib.proxy)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans.factory.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cache)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans.factory)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.dao.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.beans.factory.xml)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.dao)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.data.redis.core.query)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.data.redis.listener)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.data.redis.serializer)(version>=1.0.0)(!(version>=2.0.0))) camel-spring-redis package:(&(package=org.springframework.beans.factory.config)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.convert)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.context)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.cache.support)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.task)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.util)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support package:(&(package=org.springframework.core.convert.converter)(version>=4.0.9)(!(version>=4.1.0))) Spring Data Redis Support at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:405) at Proxy98710470_5a90_4a34_b58d_eca7f8db2bee.installFeature(Unknown Source) at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:72) at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:38) at org.apache.karaf.shell.console.AbstractAction.execute(AbstractAction.java:33)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:39)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.karaf.shell.commands.basic.AbstractCommand.execute(AbstractCommand.java:33)[27:org.apache.karaf.shell.console:3.0.5] at Proxy9afd6562_cd3d_4d8a_9ab0_ec37d183d83a.execute(Unknown Source)[:] at Proxy9afd6562_cd3d_4d8a_9ab0_ec37d183d83a.execute(Unknown Source)[:] at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:480)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:406)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:182)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:119)[27:org.apache.karaf.shell.console:3.0.5] at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:94) at org.apache.karaf.shell.console.impl.jline.ConsoleImpl.run(ConsoleImpl.java:210) at org.apache.karaf.shell.console.impl.jline.LocalConsoleManager$2$1$1.run(LocalConsoleManager.java:109) at java.security.AccessController.doPrivileged(Native Method)[:1.8.0_51] at org.apache.karaf.jaas.modules.JaasHelper.doAs(JaasHelper.java:57)[28:org.apache.karaf.jaas.modules:3.0.5] at org.apache.karaf.shell.console.impl.jline.LocalConsoleManager$2$1.run(LocalConsoleManager.java:102)[27:org.apache.karaf.shell.console:3.0.5]
    No Bugmate found.